Bug #75250 [Com]: Installation fails with INSTALL_ROOT when httpd.conf file is not present

From: Date: Sat, 23 Sep 2017 21:54:56 +0000
Subject: Bug #75250 [Com]: Installation fails with INSTALL_ROOT when httpd.conf file is not present
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-211335@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=75250&edit=1 ID: 75250 Comment by: spam2 at rhsoft dot net Reported by: peterkokot at gmail dot com Summary: Installation fails with INSTALL_ROOT when httpd.conf file is not present Status: Open Type: Bug Package: Apache2 related PHP Version: Irrelevant Block user comment: N Private report: N New Comment: Problem seems to be that it likes to put mod_php in the httpd conf5 hence we included long ago a fake httpd.conf in our rpmbuild, AFAIK touching the file should be enough and YES this is a bug - but likely not in PHP but apxs as you can see who throws the error Previous Comments: ------------------------------------------------------------------------ [2017-09-23 19:06:04] peterkokot at gmail dot com Description: ------------ When building PHP from source: ./configure --disable-all --with-apxs2 make make INSTALL_ROOT="/opt/myphp" install and /opt/myphp is empty, the installation fails with the following error: apxs:Error: Config file /opt/myphp/etc/apache2/httpd.conf not found. ------------------------------------------------------------------------ -- Edit this bug report at https://bugs.php.net/bug.php?id=75250&edit=1

« previous php.bugs (#211335) next »