Req #34882 [Asn->Opn]: Unable to access *original* posted variable name with dot in

From: Date: Tue, 24 Oct 2017 06:03:48 +0000
Subject: Req #34882 [Asn->Opn]: Unable to access *original* posted variable name with dot in
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-211969@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=34882&edit=1 ID: 34882 Updated by: kalle@php.net Reported by: theo at crazygreek dot co dot uk Summary: Unable to access *original* posted variable name with dot in -Status: Assigned +Status: Open Type: Feature/Change Request Package: *General Issues Operating System: Linux PHP Version: 6CVS -Assigned To: bishop +Assigned To: Block user comment: N Private report: N Previous Comments: ------------------------------------------------------------------------ [2015-10-06 20:41:19] bishop@php.net Duplicated by https://bugs.php.net/bug.php?id=42055. ------------------------------------------------------------------------ [2010-12-22 12:42:04] johannes@php.net making this a ini setting is incredible pain for writing portable applications. I wonder whether it makes sense to add the element two times to the $_GET / $_POST array - once in replaced and once in non-replaced form.But that might be confusing too. Maybe the best thing is to do the hard cut and break BC. ------------------------------------------------------------------------ [2005-10-16 01:21:02] derick@php.net This should IMO not be any ini setting, but it would make sense not to touch variable names in cases where register_globals is disabled. We should get rid of register_globals altogether in PHP 6, and then we can change this behavior too. ------------------------------------------------------------------------ [2005-10-15 23:54:33] pookey@php.net confirmed main/php_variables.c, line 106 ------------------------------------------------------------------------ [2005-10-15 23:39:22] theo at crazygreek dot co dot uk Description: ------------ PHP automagically converts the '.' char in POST/GET field names to '_'. While i am fully aware as to why it does it, there is are a number arguments for being able to turn off this 'feature': (a) There is no way to change a field name 'animal.moo_cows' back to it's original form other than manually parsing the POST/GET data. (b) For those silly enough to be using register globals, $moo.cows may not be a valid variable - but then neither is $moo:cows, or $moo!cows, yet : and ! are not converted into underscores. where is the logic in that? Having a ini setting or some such to be able to turn off this rather messed up behaviour would be very useful. ------------------------------------------------------------------------ -- Edit this bug report at https://bugs.php.net/bug.php?id=34882&edit=1

« previous php.bugs (#211969) next »