#19714 [Opn->Bgs]: Using default user in OCI8 functions

From: Date: Wed, 02 Oct 2002 13:14:41 +0000
Subject: #19714 [Opn->Bgs]: Using default user in OCI8 functions
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-21272@lists.php.net to get a copy of this message
ID: 19714 Updated by: sniper@php.net Reported By: jomar@hafro.is -Status: Open +Status: Bogus Bug Type: OCI8 related Operating System: SunOS PHP Version: 4.2.2 New Comment: You should be setting those environment variables in the SHELL not in apache httpd.. See http://www.php.net/manual/en/ref.oci8.php for more information. Previous Comments: ------------------------------------------------------------------------ [2002-10-02 08:04:17] jomar@hafro.is I´m using Apache enviroment : SetEnv ORACLE_HOME /usr/oracle SetEnv ORA_NLS33 /usr/oracle/ocommon/nls/admin/data SetEnv NLS_LANG icelandic_america I also set the tns_names and more env within root enviroment before I execute apachectl start running php as a module. I also compiled Php with Oci8. I´m having trouble with ocilogon function when I use the ocilogon("/","") (default user/nopass,server) If I logon using a valid username and password then it is ok, but when I use this method it returns an ora error : ORA-01005: null password given; logon denied I also have the ora libs and if I use ora_logon("/","") that seems to work. ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=19714&edit=1

« previous php.bugs (#21272) next »