Bug #75848 [NEW]: Can not start php7.2-fpm because 'clear_env' is an unkown entry

From: Date: Fri, 19 Jan 2018 13:38:15 +0000
Subject: Bug #75848 [NEW]: Can not start php7.2-fpm because 'clear_env' is an unkown entry
Groups: php.bugs 
Request: Send a blank email to php-bugs+get-213617@lists.php.net to get a copy of this message
From:             gifsucher at hotmail dot de
Operating system: Debian 9 (Stretch)
PHP version:      7.2.1
Package:          FPM related
Bug Type:         Bug
Bug description:Can not start php7.2-fpm because 'clear_env' is an unkown entry

Description:
------------
I use Debian 9 (Stretch) with latest nginx and php7.2 fpm which is all
configured well.

Now I want to use nextcloud but this want access to 'env[PATH]' which
isn't working over PHP 'getenv(PATH)' so it errors out.

I found in http://php.net/manual/en/install.fpm.configuration.php
the
value "clear_env" which is set by default to true/yes so I added it in
php-fpm.conf and are getting now "unkkown entry 'clear_env'".

I used before sysvinit-core and replaced it with systemd-sysv because of
"Thanks for the report. Well, unfortunately php-fpm without systemd
support doesn't recognise this configuration option." But I could not
found the related bug to this.

I hope that someone can lookup for this and tell me what went wrong or
if this is now a bug in 7.2.1 fpm.

Expected result:
----------------
PHP 7.2 FPM runs after adding 'clear_env = no'

Actual result:
--------------
[....] Starting php7.2-fpm (via systemctl): php7.2-fpm.serviceJob for
php7.2-fpm.service failed because the control process exited with error
code.
See "systemctl status php7.2-fpm.service" and "journalctl -xe" for
details.
 failed!

root@host /etc/init.d # systemctl status php7.2-fpm.service
● php7.2-fpm.service - The PHP 7.2 FastCGI Process Manager
   Loaded: loaded (/lib/systemd/system/php7.2-fpm.service; enabled;
vendor preset: enabled)
   Active: failed (Result: exit-code) since Fri 2018-01-19 14:34:48 CET;
1min 23s ago
     Docs: man:php-fpm7.2(8)
  Process: 6779 ExecStart=/usr/sbin/php-fpm7.2 --nodaemonize
--fpm-config /etc/php/7.2/fpm/php-fpm.conf (code=exited, status=78)
 Main PID: 6779 (code=exited, status=78)

Jan 19 14:34:48 host systemd[1]: Starting The PHP 7.2 FastCGI Process
Manager...
Jan 19 14:34:48 host php-fpm7.2[6779]: [19-Jan-2018 14:34:48] ERROR:
[/etc/php/7.2/fpm/php-fpm.conf:109] unknown entry 'clear_env'
Jan 19 14:34:48 host php-fpm7.2[6779]: [19-Jan-2018 14:34:48] ERROR:
failed to load configuration file '/etc/php/7.2/fpm/php-fpm.conf'
Jan 19 14:34:48 host php-fpm7.2[6779]: [19-Jan-2018 14:34:48] ERROR: FPM
initialization failed
Jan 19 14:34:48 host systemd[1]: php7.2-fpm.service: Main process
exited, code=exited, status=78/n/a
Jan 19 14:34:48 host systemd[1]: Failed to start The PHP 7.2 FastCGI
Process Manager.
Jan 19 14:34:48 host systemd[1]: php7.2-fpm.service: Unit entered failed
state.
Jan 19 14:34:48 host systemd[1]: php7.2-fpm.service: Failed with result
'exit-code'.


-- 
Edit bug report at https://bugs.php.net/bug.php?id=75848&edit=1
-- 
Try a snapshot (PHP 5.4):   https://bugs.php.net/fix.php?id=75848&r=trysnapshot54
Try a snapshot (PHP 5.5):   https://bugs.php.net/fix.php?id=75848&r=trysnapshot55
Try a snapshot (trunk):     https://bugs.php.net/fix.php?id=75848&r=trysnapshottrunk
Fixed in SVN:               https://bugs.php.net/fix.php?id=75848&r=fixed
Fixed in release:           https://bugs.php.net/fix.php?id=75848&r=alreadyfixed
Need backtrace:             https://bugs.php.net/fix.php?id=75848&r=needtrace
Need Reproduce Script:      https://bugs.php.net/fix.php?id=75848&r=needscript
Try newer version:          https://bugs.php.net/fix.php?id=75848&r=oldversion
Not developer issue:        https://bugs.php.net/fix.php?id=75848&r=support
Expected behavior:          https://bugs.php.net/fix.php?id=75848&r=notwrong
Not enough info:            https://bugs.php.net/fix.php?id=75848&r=notenoughinfo
Submitted twice:            https://bugs.php.net/fix.php?id=75848&r=submittedtwice
register_globals:           https://bugs.php.net/fix.php?id=75848&r=globals
PHP 4 support discontinued: https://bugs.php.net/fix.php?id=75848&r=php4
Daylight Savings:           https://bugs.php.net/fix.php?id=75848&r=dst
IIS Stability:              https://bugs.php.net/fix.php?id=75848&r=isapi
Install GNU Sed:            https://bugs.php.net/fix.php?id=75848&r=gnused
Floating point limitations: https://bugs.php.net/fix.php?id=75848&r=float
No Zend Extensions:         https://bugs.php.net/fix.php?id=75848&r=nozend
MySQL Configuration Error:  https://bugs.php.net/fix.php?id=75848&r=mysqlcfg



Thread (4 messages)

« previous php.bugs (#213617) next »