Req->Bug #65169 [Opn->Ver]: php-cgi: Content-type before Directive no longer available

From: Date: Wed, 14 Mar 2018 13:59:18 +0000
Subject: Req->Bug #65169 [Opn->Ver]: php-cgi: Content-type before Directive no longer available
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-214352@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=65169&edit=1 ID: 65169 Updated by: cmb@php.net Reported by: spamik at yum dot pl -Summary: php-cgi: Content-type bfore Directive no longer available +Summary: php-cgi: Content-type before Directive no longer available -Status: Open +Status: Verified -Type: Feature/Change Request +Type: Bug -Package: *General Issues +Package: CGI/CLI related -PHP Version: 5.4Git-2013-06-25 (Git) +PHP Version: master-Git-2018-03-14 (Git) Block user comment: N Private report: N New Comment: Still unresolved. Previous Comments: ------------------------------------------------------------------------ [2013-07-01 07:21:19] ab@php.net Not reproducible with 5.3 ------------------------------------------------------------------------ [2013-06-30 21:02:13] spamik at yum dot pl Description: ------------ # ./php-cgi -n a.php X-Powered-By: PHP/5.4.16 Content-type: text/html # ./php-cgi -n -d magic_quotes_gpc=1 a.php <br /> <b>Fatal error</b>: Directive 'magic_quotes_gpc' is no longer available in PHP in <b>Unknown</b> on line <b>0</b><br /> expected: # ./php-cgi -n -d magic_quotes_gpc=1 a.php X-Powered-By: PHP/5.4.16 Content-type: text/html <br /> <b>Fatal error</b>: Directive 'magic_quotes_gpc' is no longer available in PHP in <b>Unknown</b> on line <b>0</b><br /> Not outputing Content-type header means that apache webserver will only return 500 error without a webmaster actualy seeing error. ------------------------------------------------------------------------ -- Edit this bug report at https://bugs.php.net/bug.php?id=65169&edit=1

« previous php.bugs (#214352) next »