Req #38129 [Opn->Fbk]: Configure fails when using IBM's V2.0 webserver
| From: | requinix@php.net | Date: | Sat, 05 May 2018 18:17:42 +0000 |
| Subject: | Req #38129 [Opn->Fbk]: Configure fails when using IBM's V2.0 webserver | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-215072@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=38129&edit=1
ID: 38129
Updated by: requinix@php.net
Reported by: j dot lammerts at chello dot nl
Summary: Configure fails when using IBM's V2.0 webserver
-Status: Open
+Status: Feedback
Type: Feature/Change Request
-Package: Feature/Change Request
+Package: *General Issues
Operating System: AIX 5
PHP Version: 5.1.4
Block user comment: N
Private report: N
New Comment:
Is this still relevant? Of course IBM HTTP Server is now 9.0 but AIX is still around.
Previous Comments:
------------------------------------------------------------------------
[2006-07-18 09:50:12] j dot lammerts at chello dot nl
Description:
------------
Normally, when IBMIHS v 2.0(.47.1) is installed, the systemwide variable LIBPATH is NOT changed.
Somewhere in the ./configure stage, the version of the webserver is tested (httpd -v). On AIX, when
LIBPATH is not set, this fails
Reproduce code:
---------------
Calling httpd -v with the LIBPATH variable NOT set to the installationpath of IBMIHS/lib, produces
this error :
exec(): 0509-036 Cannot load program /usr/IBMIHS/bin/httpd because of the following errors
:
0509-150 Dependent module libaprutil-0.so could not be loaded.
0509-022 Cannot load module libaprutil-0.so.
0509-026 System error: A file or directory in the path name does not exist.
This error causes the configure script to fail horribly...
Expected result:
----------------
The expected result can be obtained by setting the LIBPATH variable before starting the configure
script :
export LIBPATH=$LIBPATH:/usr/IBMIHS/lib
(or set it to wherever the lib directory for this instance of the webserver is located)
(test by calling /usr/IBMIHS/bin/httpd -v....)
Maybe a check for a correct result of the call httpd -v can be incorporated in the configure script.
It took me weeks to figure this one out !
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=38129&edit=1