#10725 [Com]: Cannot load ISAPI file php4isapi.dll
| From: | mbuiter at hotmail dot com | Date: | Sat, 05 Oct 2002 14:51:29 +0000 |
| Subject: | #10725 [Com]: Cannot load ISAPI file php4isapi.dll | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-21567@lists.php.net to get a copy of this message | ||
ID: 10725
Comment by: mbuiter@hotmail.com
Reported By: dimitri.gunsing@nec-computers.com
Status: Closed
Bug Type: IIS related
Operating System: Windows 2000 SP1
PHP Version: 4.0.5
New Comment:
Hi all,
I think it's a shame this thread is closed, because even today, in
version PHP 4.2.3, this problem still occurs on EVERY Windows NT 4
server i try to install PHP on.
The only work-around is to use PHP as a CGI (which I don't want), or
use Windows 2000 instead of NT (the bug doesn't appear on Windows
2000!)
Does anyone know another (bttter) workaround, or solution, please let
me know!!
Previous Comments:
------------------------------------------------------------------------
[2002-02-18 18:51:48] raptor@the0rem.net
I have been experiencing the same problem, with 4.0.6 and now with
4.1.1
Event Type: Error
Event Source: W3SVC
Event Category: None
Event ID: 14
Date: 18/02/2002
Time: 4:41:59 PM
User: N/A
Computer: THE0REM-1
Description:
The HTTP Filter DLL C:\php\sapi\php4isapi.dll failed to load. The data
is the error.
For additional information specific to this message please visit the
Microsoft Online Support site located at:
http://www.microsoft.com/contentredirect.asp.
Data:
0000: 7e 00 00 00 ~...
------------------------------------------------------------------------
[2001-12-02 04:34:44] sander@php.net
No feedback. Closing.
------------------------------------------------------------------------
[2001-11-11 12:10:27] sander@php.net
Can you try upgrading to PHP-4.0.6? Does the problem still occur?
------------------------------------------------------------------------
[2001-05-08 03:57:53] dimitri.gunsing@nec-computers.com
After installing and configuring PHP 4.0.5. I can only run this version
in CGI mode. Trying to do so as an ISAPI filter it will never load the
DLL file and crash everytime with the following error in the event log
:
The HTTP Filter DLL C:\php4\sapi\php4isapi.dll failed to load. The
data is the error. Data : 7f 00 00 00
I've tried this on two seperate servers and both had the exact same
problem. Installing PHP 4.0.4pl1 is no problem, the ISAPI version
shipped with that distribution is running fine.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=10725&edit=1