Bug #50921 [Com]: '200 OK' HTTP status despite PHP error

From: Date: Tue, 10 Jul 2018 15:07:29 +0000
Subject: Bug #50921 [Com]: '200 OK' HTTP status despite PHP error
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-216263@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=50921&edit=1

 ID:                 50921
 Comment by:         drew+bug dot php dot net at mcdruid dot co dot uk
 Reported by:        phpbug at starurl dot com
 Summary:            '200 OK' HTTP status despite PHP error
 Status:             Re-Opened
 Type:               Bug
 Package:            HTTP related
 Operating System:   *
 PHP Version:        5.2.12
 Block user comment: N
 Private report:     N

 New Comment:

Note that this may sometimes be down to the CustomLog format in apache. For example
'%>s' can (correctly) yield a 403 in the access log whereas just '%s' may
record a 200 even when the status code of the response was something else.


Previous Comments:
------------------------------------------------------------------------
[2018-05-25 02:51:50] robberphex at gmail dot com

I'm trying to fix this.
Please review https://github.com/php/php-src/pull/3244.

And, Xdebug have same bug. If you are interested, see https://github.com/xdebug/xdebug/pull/420

------------------------------------------------------------------------
[2018-05-05 18:01:18] requinix@php.net

Related To: Bug #36636

------------------------------------------------------------------------
[2017-11-06 21:19:46] chealer at gmail dot com

I still experience this with XAMPP 5.6.30's PHP 5.6.30.

------------------------------------------------------------------------
[2017-10-06 13:21:05] antoine dot gilabert at gmail dot com

i've done this to solve the problem:
register_shutdown_function( "fatal_handler" );
function fatal_handler() {
    http_response_code (500);
}

------------------------------------------------------------------------
[2016-07-12 18:05:00] chealer at gmail dot com

I am experiencing this symptom under WampServer 2.5, which uses PHP 5.5.12. This happens even after
disabling Xdebug, and even though display_errors is set to On. Is this caused by the same bug?

I agree with jonathan, josh and xmeltrut; a preference could be introduced, but the default behavior
should not be the current behavior.

------------------------------------------------------------------------


The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at

    https://bugs.php.net/bug.php?id=50921


--
Edit this bug report at https://bugs.php.net/bug.php?id=50921&edit=1


Thread (33 messages)

« previous php.bugs (#216263) next »