Req #60759 [Com]: SplDoublyLinkedList->clear()

From: Date: Fri, 13 Jul 2018 13:16:39 +0000
Subject: Req #60759 [Com]: SplDoublyLinkedList->clear()
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-216301@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=60759&edit=1 ID: 60759 Comment by: shrinivas dot mahindrakar at viztarinternational dot com Reported by: dragoonis@php.net Summary: SplDoublyLinkedList->clear() Status: Open Type: Feature/Change Request Package: SPL related Operating System: N/A PHP Version: 5.4.0RC5 Block user comment: N Private report: N New Comment: // $cmd = path of my project file if (substr(php_uname(), 0, 7) == "Windows"){ pclose(popen("start /MIN ". $cmd, "r")); }else{ exec($cmd . " > /dev/null &"); } the same code is working in local system but in server its waiting for cmd and the code is not working Previous Comments: ------------------------------------------------------------------------ [2012-07-28 22:29:15] felipe@php.net It hasn't been merged, yet. Just assigned to the SPL maintainer. ------------------------------------------------------------------------ [2012-07-28 22:14:35] dragoonis@php.net Thanks for getting this merged into a version branch Felipe. Paul. ------------------------------------------------------------------------ [2012-01-15 22:37:51] dragoonis@php.net The following patch has been added/updated: Patch Name: spl_dllist_clear Revision: 1326667071 URL: https://bugs.php.net/patch-display.php?bug=60759&patch=spl_dllist_clear&revision=1326667071 ------------------------------------------------------------------------ [2012-01-15 22:37:16] dragoonis@php.net I think it's much more appropriate to rename this to clear() as it implies wiping contents of something. The original idea of reset() wasn't a good one as the term 'reset' in PHP usually refers to resetting an internal pointer of a list. New patch attached as spl_dllist_clear. ------------------------------------------------------------------------ [2012-01-15 22:29:54] dragoonis@php.net Renaming the reset() method to clear() ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at https://bugs.php.net/bug.php?id=60759 -- Edit this bug report at https://bugs.php.net/bug.php?id=60759&edit=1

« previous php.bugs (#216301) next »