Bug #75785 [Com]: Many errors from exif_read_data
| From: | jbe at geo6 dot be | Date: | Wed, 25 Jul 2018 07:24:28 +0000 |
| Subject: | Bug #75785 [Com]: Many errors from exif_read_data | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-216439@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=75785&edit=1
ID: 75785
Comment by: jbe at geo6 dot be
Reported by: opajaap at opajaap dot nl
Summary: Many errors from exif_read_data
Status: Assigned
Type: Bug
Package: EXIF related
Operating System: unknown
PHP Version: 7.2.1
Assigned To: kalle
Block user comment: N
Private report: N
New Comment:
I have the same issue since a few days.
Here is my PHP version :
PHP 7.2.7-2+0~20180714182401.1+jessie~1.gbp3fcba8 (cli) (built: Jul 15 2018 13:57:20) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies
with Zend OPcache v7.2.7-2+0~20180714182401.1+jessie~1.gbp3fcba8, Copyright (c) 1999-2018, by
Zend Technologies
Previous Comments:
------------------------------------------------------------------------
[2018-07-17 15:55:09] kalle@php.net
Thanks for the zip! I will try take a look if there is something obviously wrong in ext/exif.
Ps. I think the reason its fixed in newer versions is due to stas@ security fixes that could have
flipped the coin and actually make them work.
------------------------------------------------------------------------
[2018-07-17 09:26:34] opajaap at opajaap dot nl
Sorry, they are no longer there. Try https://betatest.opajaap.nl/wp-content/wppa-depot/opajaap/phpbug.zip
this zip contains 5 of them.
FYI: Seems to be fixed in php 7.2.7
------------------------------------------------------------------------
[2018-07-16 14:32:54] kalle@php.net
Hi, whenever I try to access the linked .jpg's, I get a WP login page, any chance you can share
them in a non protected space or zip them all?
Thanks
------------------------------------------------------------------------
[2018-07-12 13:17:17] cmb@php.net
Kalle, could you have a look at this issue, please?
------------------------------------------------------------------------
[2018-01-09 11:42:49] opajaap at opajaap dot nl
Here are the links to the images in the errorlog:
https://2013.opajaap.nl/wp-content/uploads/wppa-source/album-20/42996.jpg
https://2013.opajaap.nl/wp-content/uploads/wppa-source/album-22/43168.jpg
https://2013.opajaap.nl/wp-content/uploads/wppa-source/album-39/43186.jpg
https://2013.opajaap.nl/wp-content/uploads/wppa-source/album-43/43279.jpg
https://2013.opajaap.nl/wp-content/uploads/wppa-source/album-13/43303.jpg
https://2013.opajaap.nl/wp-content/uploads/wppa-source/album-43/43355.jpg
https://2013.opajaap.nl/wp-content/uploads/wppa-source/album-3/43356.jpg
https://2013.opajaap.nl/wp-content/uploads/wppa-source/album-3/43357.jpg
https://2013.opajaap.nl/wp-content/uploads/wppa-source/album-3/43358.jpg
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
https://bugs.php.net/bug.php?id=75785
--
Edit this bug report at https://bugs.php.net/bug.php?id=75785&edit=1