#19787 [Opn->]: Can not load module

From: Date: Sun, 06 Oct 2002 22:45:31 +0000
Subject: #19787 [Opn->]: Can not load module
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-21668@lists.php.net to get a copy of this message
ID: 19787 Updated by: rasmus@php.net Reported By: matt@unix4all.serveftp.com -Status: Open +Status: Won\'t fix Bug Type: Apache2 related Operating System: FreeBSD 4.5 PHP Version: 4.2.3 New Comment: PHP 4.2.x does not really support Apache 2. It's sort of hit and miss. Not sure why you would use Apache2 on FreeBSD as Apache2 doesn't support threading on that platform. I strongly suggest sticking with Apache1. Previous Comments: ------------------------------------------------------------------------ [2002-10-06 16:30:17] matt@unix4all.serveftp.com I have a pretty serious problem with php and apache. I configured apache like the following: ./configure --prefix=/wwwserv2 --enable-modssl --with-ssl=/usr/local/ssl --enable-cgi --enable-so then i did a make make install then I tested apache at this point to see if it worked and it works fine after the initial installation. Then I untared php-4.2.3 and configured it like the following: ./configure --with-apxs2=/wwwserv2/bin/apxs then i did a make make install after this got done, I tried to start apache with /wwwserv2/bin/apachectl start and I got the following error alphatest# /wwwserv2/bin/apachectl start Syntax error on line 230 of /wwwserv2/conf/httpd.conf: Cannot load /wwwserv2/modules/libphp4.so into server: /wwwserv2/modules/libphp4.so: Undefined symbol "pthread_getspecific" If it changes anything this freebsd box is a digital with a alpha processor. I hope you can repair this problem. Thanx ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=19787&edit=1

« previous php.bugs (#21668) next »