Bug #76724 [Ver]: Unable to start session when using PHP CGI

From: Date: Thu, 09 Aug 2018 09:17:49 +0000
Subject: Bug #76724 [Ver]: Unable to start session when using PHP CGI
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-216683@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=76724&edit=1 ID: 76724 User updated by: geral at braldesign dot com Reported by: geral at braldesign dot com Summary: Unable to start session when using PHP CGI Status: Verified Type: Bug Package: Session related Operating System: CLOUDLINUX 6.10 standard PHP Version: 7.2.8 Block user comment: N Private report: N New Comment: Then, there is no way to use a session with a quiet script? thanks. Previous Comments: ------------------------------------------------------------------------ [2018-08-09 09:14:31] requinix@php.net -q deliberately makes the scripting engine think that headers have been sent, but it's been that way for so long that I can't say exactly why it does so. I can only assume there is/was a good reason. ------------------------------------------------------------------------ [2018-08-09 07:21:45] geral at braldesign dot com Description: ------------ When executing the script with PHP CGI 7.2 and the flag "-q" it will generate one warning. When not using thr flag it works as expected. Test script: --------------- <?php ini_set('display_errors', 1); ini_set('display_startup_errors', 1); error_reporting(E_ALL); session_start(); Expected result: ---------------- no warning nor errors. Actual result: -------------- <b>Warning</b>: session_start(): Cannot start session when headers already sent in ... on line <b>7</b> ------------------------------------------------------------------------ -- Edit this bug report at https://bugs.php.net/bug.php?id=76724&edit=1

« previous php.bugs (#216683) next »