Bug #76817 [Opn]: Can't establish a connection to MySQL after upgrading from 7.2.9 to 7.3.0beta3

From: Date: Thu, 30 Aug 2018 09:26:46 +0000
Subject: Bug #76817 [Opn]: Can't establish a connection to MySQL after upgrading from 7.2.9 to 7.3.0beta3
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-216802@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=76817&edit=1 ID: 76817 User updated by: ildar dot aim at gmail dot com Reported by: ildar dot aim at gmail dot com Summary: Can't establish a connection to MySQL after upgrading from 7.2.9 to 7.3.0beta3 Status: Open Type: Bug -Package: MySQL related +Package: MySQLi related Operating System: archlinux 64 -PHP Version: 7.3.0beta2 +PHP Version: 7.3.0beta3 Block user comment: N Private report: N New Comment: a code like $link = mysqli_connect($host, $sql_user, $sql_password); is used. Previous Comments: ------------------------------------------------------------------------ [2018-08-30 09:24:10] ildar dot aim at gmail dot com Description: ------------ The script is same as in https://bugs.php.net/bug.php?id=76651 | default_authentication_plugin | mysql_native_password | mysql Ver 8.0.12 for Linux on x86_64 (MySQL Community Server (GPL)) Test script: --------------- Should you add beta3 in the 'PHP version:' select box ? Actual result: -------------- Warning: mysqli_connect(): (HY000/2002): No such file or directory in /home/aim/public_html/p.php on line 10 Error: Unable to connect to MySQL. Debugging errno: 2002 Debugging error: No such file or directory ------------------------------------------------------------------------ -- Edit this bug report at https://bugs.php.net/bug.php?id=76817&edit=1

« previous php.bugs (#216802) next »