Bug #76928 [Com]: Unable to connect via TLS 1.2
Edit report at https://bugs.php.net/bug.php?id=76928&edit=1
ID: 76928
Comment by: aurelien dot grimal at tech-tips dot fr
Reported by: post at rolandgruber dot de
Summary: Unable to connect via TLS 1.2
Status: Open
Type: Bug
Package: IMAP related
Operating System: Linux
PHP Version: 7.2.10
Block user comment: N
Private report: N
New Comment:
The problem is only concerning IMAP with StartTLS (port 143) and not direct SSL on IMAPS (port 993).
So IMAP with StartTLS can't use further than TLS1.0, and IMAP on SSL can use TLS1.2.
Previous Comments:
------------------------------------------------------------------------
[2018-09-24 18:04:42] post at rolandgruber dot de
Description:
------------
It seems that the PHP IMAP module depends on some old library (libc-client2007e) that does not
support TLS v1.2. On imap_open() an error "TLS/SSL failure for <my_imap_server>: SSL
negotiation failed" is reported.
Please support recent TLS versions. This is also a security issue.
User report:
The IMAP server is running cyrus 2.5.
I had to modify the parameter tls_versions in /etc/imapd.conf from
tls_versions: tls1_2 to
tls_versions: tls1_0 tls1_1 tls1_2
to make the imapAccess work, which is less secure now.
Expected result:
----------------
IMAP connections with TLS v1.2 are working.
Actual result:
--------------
TLS/SSL failure for <my_imap_server>: SSL negotiation failed
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=76928&edit=1
Thread (7 messages)