Req #77108 [NEW]: Use SNI with TLS
| From: | christian at rishoj dot net | Date: | Mon, 05 Nov 2018 08:34:09 +0000 |
| Subject: | Req #77108 [NEW]: Use SNI with TLS | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-217826@lists.php.net to get a copy of this message | ||
From: christian at rishoj dot net
Operating system: Ubuntu Linux
PHP version: 7.2.11
Package: IMAP related
Bug Type: Feature/Change Request
Bug description:Use SNI with TLS
Description:
------------
Using PHP 7.2.11 with OpenSSL 1.1.1, the IMAP extension fails to connect
to Gmail.
Quoting from the bug tracker of Python's imaplib2, which was affected by
the same issue:
> This is because [IMAP extension] does not support SNI, and Google
returns an invalid certificate in that case.
>
> Some sites want to encourage the use of SNI and configure a default
certificate that fails WebPKI authentication when the client supports
TLS 1.3.
The IMAP extension should use SNI if TLS version is 1.3.
Actual result:
--------------
Error message when connecting to Gmail:
> RuntimeException: Certificate failure for imap.gmail.com: self signed
certificate: /OU=No SNI provided; please fix your
client./CN=invalid2.invalid
--
Edit bug report at https://bugs.php.net/bug.php?id=77108&edit=1
--
Try a snapshot (PHP 5.4): https://bugs.php.net/fix.php?id=77108&r=trysnapshot54
Try a snapshot (PHP 5.5): https://bugs.php.net/fix.php?id=77108&r=trysnapshot55
Try a snapshot (trunk): https://bugs.php.net/fix.php?id=77108&r=trysnapshottrunk
Fixed in SVN: https://bugs.php.net/fix.php?id=77108&r=fixed
Fixed in release: https://bugs.php.net/fix.php?id=77108&r=alreadyfixed
Need backtrace: https://bugs.php.net/fix.php?id=77108&r=needtrace
Need Reproduce Script: https://bugs.php.net/fix.php?id=77108&r=needscript
Try newer version: https://bugs.php.net/fix.php?id=77108&r=oldversion
Not developer issue: https://bugs.php.net/fix.php?id=77108&r=support
Expected behavior: https://bugs.php.net/fix.php?id=77108&r=notwrong
Not enough info: https://bugs.php.net/fix.php?id=77108&r=notenoughinfo
Submitted twice: https://bugs.php.net/fix.php?id=77108&r=submittedtwice
register_globals: https://bugs.php.net/fix.php?id=77108&r=globals
PHP 4 support discontinued: https://bugs.php.net/fix.php?id=77108&r=php4
Daylight Savings: https://bugs.php.net/fix.php?id=77108&r=dst
IIS Stability: https://bugs.php.net/fix.php?id=77108&r=isapi
Install GNU Sed: https://bugs.php.net/fix.php?id=77108&r=gnused
Floating point limitations: https://bugs.php.net/fix.php?id=77108&r=float
No Zend Extensions: https://bugs.php.net/fix.php?id=77108&r=nozend
MySQL Configuration Error: https://bugs.php.net/fix.php?id=77108&r=mysqlcfg