Bug #76224 [Com]: Error and shutdown handlers triggered on object destroy
| From: | php at mokraemer dot de | Date: | Fri, 23 Nov 2018 10:57:29 +0000 |
| Subject: | Bug #76224 [Com]: Error and shutdown handlers triggered on object destroy | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-218102@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=76224&edit=1
ID: 76224
Comment by: php at mokraemer dot de
Reported by: we at mokraemer dot de
Summary: Error and shutdown handlers triggered on object
destroy
Status: Re-Opened
Type: Bug
Package: FPM related
Operating System: Linux Mageia 6
PHP Version: 7.2
Block user comment: N
Private report: N
New Comment:
I'll do a test without opcache. Since this is production environment, I have to schedule it.
Reloading config with SIGUSR2 does not work. If you do, the running php-fpm instance is not
functional any more.
Previous Comments:
------------------------------------------------------------------------
[2018-11-23 09:31:36] requinix@php.net
Only if opcache is enabled?
------------------------------------------------------------------------
[2018-11-23 09:27:49] php at mokraemer dot de
Just updated to php 7.2.11. Still the same error. This happens if php opcache is enabled.
------------------------------------------------------------------------
[2018-06-24 04:25:44] php-bugs at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
------------------------------------------------------------------------
[2018-04-15 13:28:35] spam2 at rhsoft dot net
can you reproduce that with any supported version?
breaking news: php5 is dead, PHP 7.0 is EOL
7.1/7.2 are active supported
anything below only for critical security issues
------------------------------------------------------------------------
[2018-04-15 13:25:23] we at mokraemer dot de
Description:
------------
I get errors like
"Maximum execution time of 30 seconds exceeded" hours after the real request was
successfully served.
Together with errors from a registered shutdown handler which is triggered.
My assumption is, the object stays in RAM for reuse and on cleanup the shutdown handler is
triggered.
_Server[REQUEST_TIME_FLOAT] => 1523715452.2153
Time of the triggered error 1523742703
Which is 27251 seconds after the request and ~7.5 hours later.
- PHP 5.6.35 (cli) (built: Mar 31 2018 15:35:22)
- Extensions:
Core,date,ereg,libxml,pcre,Reflection,SPL,SimpleXML,hash,bz2,ctype,curl,dom,session,openssl,zlib,gd,gettext,iconv,standard,intl,mbstring,mcrypt,fileinfo,mysqlnd,mysqli,pcntl,posix,exif,soap,imap,sysvmsg,sysvsem,sysvshm,tokenizer,xml,xmlreader,xmlwriter,bcmath,PDO,pdo_mysql,filter,json,zip,Phar,timezonedb,memcached,wbxml,xdebug
Is there any more information I can provide? I don't know how to track this down.
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=76224&edit=1