Bug #75612 [Com]: php-mysqli build fails with MariaDB-10.2

From: Date: Wed, 28 Nov 2018 10:00:12 +0000
Subject: Bug #75612 [Com]: php-mysqli build fails with MariaDB-10.2
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-218173@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=75612&edit=1

 ID:                 75612
 Comment by:         m0r1arty dot nv at yandex dot ru
 Reported by:        dkasyanov at cloudlinux dot com
 Summary:            php-mysqli build fails with MariaDB-10.2
 Status:             Open
 Type:               Bug
 Package:            MySQLi related
 Operating System:   Centos 7
 PHP Version:        7.1.12
 Block user comment: N
 Private report:     N

 New Comment:

For temporary solution: after configure open Makefile in root php src directory,look
"-I/usr/include/mysql" and replace to "-I/usr/include/mysql/server".


Previous Comments:
------------------------------------------------------------------------
[2018-04-28 00:03:25] requinix@php.net

Related To: Bug #76282

------------------------------------------------------------------------
[2018-04-07 20:43:46] spam2 at rhsoft dot net

we use mysqlnd since 2010 everywhere and i don't get why it should be a problem for mysqli -
until you configure with shared both are directly in teh binary

[harry@srv-rhsoft:/lib64/php/modules]$ ls | grep mysql
-rwxr-xr-x 1 root root 131K 2018-04-07 19:33 mysqli.so
-rwxr-xr-x 1 root root 290K 2018-04-07 19:33 mysqlnd.so

------------------------------------------------------------------------
[2018-04-07 20:39:49] bero at lindev dot ch

One reason not to use mysqlnd is --enable-embedded-mysqli -- other than that, mysqlnd should do the
trick (but needs some testing on our side -- we know libmysql to work from years of using it).

------------------------------------------------------------------------
[2018-04-06 22:05:54] spam2 at rhsoft dot net

why don't you just build with mysqlnd - IMHO the libmysql stuff should have been removed from
php many years ago

------------------------------------------------------------------------
[2018-04-06 20:06:23] bero at lindev dot ch

Same issue here on OpenMandriva with MariaDB 10.3 -- attaching a patch that makes it build and
essentially work, but I'm not sure I've handled the removal of st_mysql->reconnect
correctly.

------------------------------------------------------------------------


The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at

    https://bugs.php.net/bug.php?id=75612


--
Edit this bug report at https://bugs.php.net/bug.php?id=75612&edit=1


Thread (9 messages)

« previous php.bugs (#218173) next »