Bug #77392 [Com]: ./configure fails on OpenSSL library searches

From: Date: Thu, 10 Jan 2019 15:05:16 +0000
Subject: Bug #77392 [Com]: ./configure fails on OpenSSL library searches
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-218884@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=77392&edit=1 ID: 77392 Comment by: bugs dot php dot net at mundpropaganda dot net Reported by: john dot iliffe at iliffe dot ca Summary: ./configure fails on OpenSSL library searches Status: Open Type: Bug Package: *Configuration Issues Operating System: Linux PHP Version: 7.3.0 Block user comment: N Private report: N New Comment: "-qversion" should be perfectly fine. It caters to older versions of gcc. I think you need to provide the directory _prefix_ to "--with-openssl", not the actual openssl directory. So if your openssl install really lives in "/usr/openssl-1.1.0i", you need to create a symlink à la "/usr/openssl -> /usr/openssl-1.1.0i" and run configure with "--with-openssl=/usr" See also: http://php.net/manual/en/openssl.installation.php#115909 Previous Comments: ------------------------------------------------------------------------ [2018-12-31 22:11:20] john dot iliffe at iliffe dot ca Description: ------------ This report contains elements of bug reports 72363 (PHP 7.0 and 7.1 and 75726 (PHP 7.1.12). Note the non-standard location of OpenSSL on my server. It appears that the with-openssl= configuration variable is not being picked up. ./configure prefix=/usr/php-7.3.0 --enable-fpm --with-fpm-user=phpfpm --with-libdir=lib64 --with-fpm-group=phpfpm --with-fpm-systemd --disable-short-tags --with-openssl=/usr/openssl-1.1.0i --with-pcre-regex --with-imap=/usr/lib64 --with-imap-ssl=/usr/openssl-1.1.0i/include/openssl --with-pgsql=/usr/postgres-9.6.2/bin --enable-zip --with-pear Fails with one of several errors: configure: error: Cannot find OpenSSL's libraries - can sometimes be resolved by changing to with-openssl=/usr/openssl-1.1.0i/lib but this leads to configure: error: Cannot find OpenSSL's <evp.h> - can resolve this by coding the FULL path to the include libraries: OPENSSL_INCDIR=/usr/openssl-1.1.0i/include/openssl in line 19052 and several other places where it occurs. Unfortunately, this messes up libs again. There is a typo in lines 3843 and 45626 of the configure file, "-qversion" should be "--version". It gives a configure fatal error when encountered but the configuration continues anyway, at least to the errors above. Test script: --------------- The ./configure shown in the previous section Expected result: ---------------- I would expect a valid make file for the compile step. ------------------------------------------------------------------------ -- Edit this bug report at https://bugs.php.net/bug.php?id=77392&edit=1

« previous php.bugs (#218884) next »