Edit report at https://bugs.php.net/bug.php?id=78147&edit=1
ID: 78147
Updated by: cmb@php.net
Reported by: mario dot bandeira at cronobandeira dot com
Summary: Memory leak after upgrade to 7.2.19
-Status: Feedback
+Status: Open
Type: Bug
-Package: IIS related
+Package: opcache
Operating System: Windows Server 2016 Standard
PHP Version: 7.2.19
-Assigned To: cmb
+Assigned To:
Block user comment: N
Private report: N
Previous Comments:
------------------------------------------------------------------------
[2019-06-12 14:21:06] mendel at spotlightdesign dot com
Same issue, a few more details.
Windows 2012/IIS/Plesk Onyx 17.8.11
Several websites with no recent changes, only change is plesk updating PHP 7.2 to 7.2.19 https://docs.plesk.com/release-notes/onyx/change-log/#contents-17811-mu55
Yes it is using opcache.
------------------------------------------------------------------------
[2019-06-11 19:39:13] nikic@php.net
Are you using opcache?
------------------------------------------------------------------------
[2019-06-11 19:11:14] mario dot bandeira at cronobandeira dot com
Description:
------------
Server was working ok on 08.06.2019
An upgrade was made to php 7.2.19 on 09.06.2019 at 2am
Problem: Server crashes after period of time (seams related to number of requests).
We could see that a a point of the code a simple echo with variables were giving the error:
[09-Jun-2019 17:43:16 UTC] PHP Fatal error: Allowed memory size of 268435456 bytes exhausted (tried
to allocate 7093009363071360192 bytes) in C:\Inetpub\vhosts\cronobandeira.com\httpdocs\cnr\index.php
on line 389
The variable in question was a integer. If we remove that variable from the echo the problem was on
the next variable evaluated.
We have checked all system configuration and the only change was the upgrade of php.
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=78147&edit=1