Bug #78103 [Opn]: Allocating ~2TB memory after PHP_FCGI_CHILDREN-th request
| From: | cmb@php.net | Date: | Wed, 12 Jun 2019 19:53:37 +0000 |
| Subject: | Bug #78103 [Opn]: Allocating ~2TB memory after PHP_FCGI_CHILDREN-th request | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-221255@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=78103&edit=1
ID: 78103
Updated by: cmb@php.net
Reported by: hardaqa at gmail dot com
Summary: Allocating ~2TB memory after PHP_FCGI_CHILDREN-th
request
Status: Open
Type: Bug
Package: CGI/CLI related
Operating System: Windows 10 v1809 64bit
PHP Version: 7.2.19
Block user comment: N
Private report: N
New Comment:
Have you double-checked (e.g. via phpinfo()) that Opcache is
indeed disabled?
Previous Comments:
------------------------------------------------------------------------
[2019-06-12 15:57:10] mario dot bandeira at cronobandeira dot com
Seams somehow related to the bug I am experiencing: https://bugs.php.net/bug.php?id=78147
---
After n-th request (n = PHP_FCGI_CHILDREN) to test.php script, php throws "Fatal error:
Allowed memory size of 536870912 bytes exhausted (tried to allocate 2052604301400 bytes)"
---
Never less, on my case it occurs with or without opcache enable.
------------------------------------------------------------------------
[2019-06-05 20:29:11] davesw dot z dot phpbug at spamgourmet dot com
I ran into the same issue, but using IIS with FastCGI. A few requests would work, and then all would
fail with trying to allocate 7813304906544536728 bytes!
Disabling opcache didn't help, reverting to 7.1.30 did (my ISP didn't offer 7.2.18 as an
option to revert to).
------------------------------------------------------------------------
[2019-06-04 21:59:49] cmb@php.net
Related To: Bug #78106
------------------------------------------------------------------------
[2019-06-04 12:07:09] hardaqa at gmail dot com
Description:
------------
Using Apache 2.4 via mod_proxy to connect to php.
PHP's using PHP_FCGI_CHILDREN to manage workers pool, opcache enabled.
After n-th request (n = PHP_FCGI_CHILDREN) to test.php script, php throws "Fatal error:
Allowed memory size of 536870912 bytes exhausted (tried to allocate 2052604301400 bytes)"
Does not occur with either opcache disabled, PHP_FCGI_CHILDREN=0 or 7.2.18 and other versions of
php.
Test script:
---------------
# run.cmd
SET PHP_FCGI_CHILDREN=4
php-cgi.exe -b 127.0.0.1:9000
# test.php
<?php
$i = 1;
define('test' . $i, 'frewgfrwfrwfg43gt53hgt5ege5wqh4g5q4w');
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=78103&edit=1