Bug #78889 [NEW]: php-fpm service fails to start
| From: | glitsj16 at riseup dot net | Date: | Fri, 29 Nov 2019 21:30:26 +0000 |
| Subject: | Bug #78889 [NEW]: php-fpm service fails to start | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-223954@lists.php.net to get a copy of this message | ||
From: glitsj16 at riseup dot net
Operating system: Arch Linux
PHP version: 7.4.0
Package: FPM related
Bug Type: Bug
Bug description:php-fpm service fails to start
Description:
------------
php-fpm.service fails to start after upgrading to php 7.4.0. Using the
default configuration files.
systemctl status php-fpm.service:
systemd[1]: Starting The PHP FastCGI Process Manager...
php-fpm[10704]: [ERROR] [pool www] failed to chown() the socket
'/run/php-fpm/php-fpm.sock': Operation not permitted (1)
php-fpm[10704]: [ERROR] [pool www] failed to chown() the socket
'/run/php-fpm/php-fpm.sock': Operation not permitted (1)
php-fpm[10704]: [ERROR] FPM initialization failed
php-fpm[10704]: [ERROR] FPM initialization failed
systemd[1]: php-fpm.service: Main process exited, code=exited,
status=78/CONFIG
systemd[1]: php-fpm.service: Failed with result 'exit-code'.
systemd[1]: Failed to start The PHP FastCGI Process Manager.
This has been reported in the Arch bug tracker:
https://bugs.archlinux.org/task/64683
Looks like the CapabilityBoundingSet needs to include CAP_CHOWN
--
Edit bug report at https://bugs.php.net/bug.php?id=78889&edit=1
--
Fix committed: https://bugs.php.net/fix.php?id=78889&r=fixed
Fixed in release: https://bugs.php.net/fix.php?id=78889&r=alreadyfixed
Need backtrace: https://bugs.php.net/fix.php?id=78889&r=needtrace
Need Reproduce Script: https://bugs.php.net/fix.php?id=78889&r=needscript
Try newer version: https://bugs.php.net/fix.php?id=78889&r=oldversion
Not developer issue: https://bugs.php.net/fix.php?id=78889&r=support
Expected behavior: https://bugs.php.net/fix.php?id=78889&r=notwrong
Not enough info: https://bugs.php.net/fix.php?id=78889&r=notenoughinfo
Submitted twice: https://bugs.php.net/fix.php?id=78889&r=submittedtwice
register_globals: https://bugs.php.net/fix.php?id=78889&r=globals
PHP version support discontinued: https://bugs.php.net/fix.php?id=78889&r=phptooold
Daylight Savings: https://bugs.php.net/fix.php?id=78889&r=dst
IIS Stability: https://bugs.php.net/fix.php?id=78889&r=isapi
Install GNU Sed: https://bugs.php.net/fix.php?id=78889&r=gnused
Floating point limitations: https://bugs.php.net/fix.php?id=78889&r=float
No Zend Extensions: https://bugs.php.net/fix.php?id=78889&r=nozend
MySQL Configuration Error: https://bugs.php.net/fix.php?id=78889&r=mysqlcfg