Bug #79205 [Opn->Fbk]: The procedure entry point ssl_ctx set_post_handshake_auth could not be located

From: Date: Sat, 01 Feb 2020 10:43:39 +0000
Subject: Bug #79205 [Opn->Fbk]: The procedure entry point ssl_ctx set_post_handshake_auth could not be located
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-225287@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=79205&edit=1 ID: 79205 Updated by: cmb@php.net Reported by: hamza1886 at gmail dot com Summary: The procedure entry point ssl_ctx set_post_handshake_auth could not be located -Status: Open +Status: Feedback Type: Bug Package: Dynamic loading Operating System: Windows 10 PHP Version: 7.4.2 -Assigned To: +Assigned To: cmb Block user comment: N Private report: N New Comment: Indeed, that looks like a setup issue. Especially, "Apache Lounge VC11 Server" is likely a problem in combination with PHP 7.4 binaries which have been built with VC15 (assuming you're using the Apache2Handler SAPI). Also make sure that you have a PHP ZTS build, and that other dependency DLLs in the PATH are up to date. Previous Comments: ------------------------------------------------------------------------ [2020-02-01 10:27:00] bugreports at gmail dot com your extension ist simply for a different php build, cleanup your system ------------------------------------------------------------------------ [2020-02-01 09:15:04] hamza1886 at gmail dot com Apache log: [Sat Feb 01 14:09:12.185298 2020] [mpm_winnt:notice] [pid 13516:tid 752] AH00455: Apache/2.4.25 (Win32) PHP/7.4.2 configured -- resuming normal operations [Sat Feb 01 14:09:12.185298 2020] [mpm_winnt:notice] [pid 13516:tid 752] AH00456: Apache Lounge VC11 Server built: Dec 20 2016 13:02:04 [Sat Feb 01 14:09:12.185298 2020] [core:notice] [pid 13516:tid 752] AH00094: Command line: 'C:\\Program Files (x86)\\EasyPHP-Devserver-17\\eds-binaries\\httpserver\\apache2425vc11x86x190116212716\\bin\\eds-httpserver.exe -d C:/Program Files (x86)/EasyPHP-Devserver-17/eds-binaries/httpserver/apache2425vc11x86x190116212716' [Sat Feb 01 14:09:12.201297 2020] [mpm_winnt:notice] [pid 13516:tid 752] AH00418: Parent: Created child process 1236 PHP Warning: PHP Startup: Unable to load dynamic library 'curl' (tried: C:\\Program Files (x86)\\EasyPHP-Devserver-17\\eds-binaries\\php\\php742vc15x86x200201130830\\ext\\curl (The specified module could not be found.), C:\\Program Files (x86)\\EasyPHP-Devserver-17\\eds-binaries\\php\\php742vc15x86x200201130830\\ext\\php_curl.dll (The specified procedure could not be found.)) in Unknown on line 0 PHP Warning: PHP Startup: Unable to load dynamic library 'intl' (tried: C:\\Program Files (x86)\\EasyPHP-Devserver-17\\eds-binaries\\php\\php742vc15x86x200201130830\\ext\\intl (The specified module could not be found.), C:\\Program Files (x86)\\EasyPHP-Devserver-17\\eds-binaries\\php\\php742vc15x86x200201130830\\ext\\php_intl.dll (The specified module could not be found.)) in Unknown on line 0 [Sat Feb 01 14:09:15.295573 2020] [mpm_winnt:notice] [pid 1236:tid 868] AH00354: Child: Starting 64 worker threads. ------------------------------------------------------------------------ [2020-02-01 09:11:47] hamza1886 at gmail dot com Description: ------------ The error occurs when starting Apache web server (v2.4.25). A popup shows with following message. I've "php_curl.dll" in the "ext" directory and it is enabled in "php.ini" file. Error message: "The procedure entry point ssl_ctx set_post_handshake_auth could not be located in the dynamic link library path_to_php_installation_dir\ext\php.curl.dll." I use: Windows 10 Pro 64-bit PHP 7.4.x TS VC15 x86 (tested with PHP 7.4.0 and PHP 7.4.2) Apache 2.4.25 x86 MySQL 5.7.17 x86 Expected result: ---------------- In case of no error, the Apache must start without errors. ------------------------------------------------------------------------ -- Edit this bug report at https://bugs.php.net/bug.php?id=79205&edit=1

« previous php.bugs (#225287) next »