Edit report at https://bugs.php.net/bug.php?id=42613&edit=1
ID: 42613
Comment by: wilsonjesica583 at gmail dot com
Reported by: patrick at baynewmedia dot com
Summary: Unable to load Dynamic Link Libraries - installer
buggy
Status: Closed
Type: Bug
Package: Windows Installer
Operating System: Windows XP Pro & Windows Vista
PHP Version: 5.2.4
Assigned To: jmertic
Block user comment: N
Private report: N
New Comment:
Windows 8 and Windows 8.1 are the versions of the famous OS of Microsoft that brought with it the
foremost significant transformation within the appearance this software from ago, giving thanks to a
replacement interface purely oriented to devices with touch technology with the aim of Arrive now,
to a replacement market. Widows 8.1 Product key's one among those essential classics which will
not be missing within our options, so it's always useful to possess at hand the generic windows
8.1 serial which will be used for installation.
https://notresponding.us/windows-8-1-product-key-activation-guide/
Previous Comments:
------------------------------------------------------------------------
[2020-02-10 10:25:18] st7smithman at gmail dot com
For testing your printer printing quality check the link <a href=âhttps://printertestpage.co/â>printer
test</a>
------------------------------------------------------------------------
[2020-02-03 06:23:50] jakecassar1947 at gmail dot com
Great job. Use Office setup. Microsoft Office setup is a suite of laptop productivity applications
that are designed specifically to be used for office or business use. https://getinfos.org/office-setup/
------------------------------------------------------------------------
[2013-07-14 09:28:55] cedricipkiss at gmail dot com
Some of the extensions require libmysql. you should make sure libmysql.dll is
installed on your computer, you can look for it under C:\Windows\System32. This is
specified in the php manual (
http://php.net/manual/en/install.windows.extensions.php).
You can download
libmysql.dll at http://www.dll-files.com/dllindex/dll-files.shtml?libmysql.
This
bug took me quite some time to solve. Hope it helps.
------------------------------------------------------------------------
[2007-11-13 17:40:02] patrick at baynewmedia dot com
"Just to clarify again, you don't need to manually adjust the php.ini
file; the installer handles that for you."
I got that, but that's simply not always the case. I appreciate what you're saying but the
problem is that, while there are claims that the extensions *should* work, they don't. I say
they don't, and the answer continues to be that they *should*. So, erm, how does this resolve
the problem again?
"I bet your script is referencing the mysql_* functions, which require
the the mysql extension. Since you are working with MySQL 5, I'd
recommend moving to the mysqli_* functions; they are mostly identical,
but support some of the newer MySQL 4.1+ features."
Actually no, I was the "mysqli_" functions (well, at least I was initially). I like using
the latest and greatest and this seemed to be the way to go. But like I said, the mysqli extension
simply doesn't work. So I had to downgrade to mysql to get it running. Again, the problem is
not really entirely solved.
"If you need multibyte support, enable the Multi-Byte String (mbstring)
extension."
Okay...not included by default with the MySQL extension so I have to edit the PHP.INI file. Granted
it's optional but clearly your first suggestion to not update the INI file really implies that
your web server will only ever do one thing, and that any time you want to do something else you
need to re-install it. If not, you should be able to install all the extensions you *think* you may
ever need...and we're right back to step 1!!!
"Any changes to the php.ini file require a restart to the web server."
...right. If I failed to omit this anywhere it's just because it was getting tedious constantly
repeating myself. But yes, I restart my we server each and every time.
"I'm marking this closed since it sounds like there isn't a PHP error
here, mainly a user configuration error."
Okay, so here's the thing. If I install PHP, I only install exactly what I need at that exact
moment, correct? If need anything else, I
a) shouldn't touch the INI file because the installer did it for me (so I'm stuck),
b) Update the INI file by hand and risk enabling a faulty extension (right back to the very top of
this problem),
c) Re-install PHP and enable the extensions I need now.
Besides that, it still doesn't answer the fundamental question and problem....if I want
functionality "A", which extensions should I be planning to install way ahead of time to
ensure that I can use it. Furthermore, why do a number of the extensions fail? The basic questions
that this whole thing started with haven't been answered or addressed in any way. The bug
summary "Unable to load Dynamic Link Libraries - installer buggy" has pretty much been
ignored. Maybe it's not an installer issue but we've managed to get so far off
topic...trying to get one precise installation going...that the original problem has been forgotten.
I'm glad I can partially use MySQL, don't get me wrong, but how has the original bug been
fixed?
------------------------------------------------------------------------
[2007-11-12 12:56:22] jmertic@php.net
Just to clarify again, you don't need to manually adjust the php.ini file; the installer
handles that for you.
I bet your script is referencing the mysql_* functions, which require the the mysql extension. Since
you are working with MySQL 5, I'd recommend moving to the mysqli_* functions; they are mostly
identical, but support some of the newer MySQL 4.1+ features.
If you need multibyte support, enable the Multi-Byte String (mbstring) extension.
Any changes to the php.ini file require a restart to the web server.
I'm marking this closed since it sounds like there isn't a PHP error here, mainly a user
configuration error.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
https://bugs.php.net/bug.php?id=42613
--
Edit this bug report at https://bugs.php.net/bug.php?id=42613&edit=1