Bug #80233 [Com]: segfault when enabling opcache php-fpm startup

From: Date: Thu, 15 Oct 2020 14:09:34 +0000
Subject: Bug #80233 [Com]: segfault when enabling opcache php-fpm startup
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-229645@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=80233&edit=1 ID: 80233 Comment by: danack@php.net Reported by: bin20060407 at gmail dot com Summary: segfault when enabling opcache php-fpm startup Status: Not a bug Type: Bug Package: opcache Operating System: CentOs 6.10 PHP Version: 7.3.23 Block user comment: N Private report: N New Comment: Well, good. But please remember to answer questions even if you think they are not relevant. Just because turning one thing off makes a segfault 'go away' doesn't mean that's the cause of the problem. Previous Comments: ------------------------------------------------------------------------ [2020-10-15 01:12:40] bin20060407 at gmail dot com Problem solved https://github.com/phalcon/cphalcon/issues/13674 ------------------------------------------------------------------------ [2020-10-15 01:11:15] bin20060407 at gmail dot com Sorry, this error is caused by an opcache problem with the phalcon extension enabled! thanks for the answer. ------------------------------------------------------------------------ [2020-10-14 13:29:35] danack@php.net Please can you confirm you have no other extensions loaded? Just because disabling opcache makes the segfault go away, doesn't necessarily mean the error lies in opcache. As this isn't affecting most people there's a good chance it's something specific to your system. Does this issue happen when you use a 'stock' config file file for php-fpm? ------------------------------------------------------------------------ [2020-10-14 06:15:49] bin20060407 at gmail dot com zend_extension = "opcache.so" disable the opcache extension, no more errors. ------------------------------------------------------------------------ [2020-10-14 03:30:55] danack@php.net The stacktrace indicates the problem is occurring in an extension. Which extensions are being loaded please? Also, please try disabling extensions to see if you can isolate which one it might be. ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at https://bugs.php.net/bug.php?id=80233 -- Edit this bug report at https://bugs.php.net/bug.php?id=80233&edit=1

« previous php.bugs (#229645) next »