Bug #80341 [NEW]: OPCache wasted memory grows rapidly and no restart after max_wasted_percentage

From: Date: Mon, 09 Nov 2020 00:09:28 +0000
Subject: Bug #80341 [NEW]: OPCache wasted memory grows rapidly and no restart after max_wasted_percentage
Groups: php.bugs 
Request: Send a blank email to php-bugs+get-230208@lists.php.net to get a copy of this message
From: alex at ndros dot com Operating system: Windows 2019 PHP version: 7.4.12 Package: opcache Bug Type: Bug Bug description:OPCache wasted memory grows rapidly and no restart after max_wasted_percentage Description: ------------ I run PHP 7.4.12 on a Windows 2019 IIS10 server. The wasted memory value in PHP Opcache grows rapidly, fills up my entire 2GB allocated to Opcache, and then opcache stops working. For example, these are the statistics after 30mins since the last webserver reset: total memory: 2.00GB used memory: 89.00MB free memory: 1.66GB wasted memory: 261.36MB (12.76%) And these are my settings: opcache.memory_consumption=2048 opcache.cache_id=oc1 opcache.error_log="D:\temp\php\opcache_errors.log" opcache.validate_timestamps=1 opcache.revalidate_freq=90 opcache.interned_strings_buffer=32 opcache.save_comments=0 opcache.max_file_size=0 opcache.file_update_protection=0 opcache.file_cache_consistency_checks=0 opcache.file_cache="D:\temp\php\opcache_filecache" opcache.max_accelerated_files=100000 If I leave it to run more time, the wasted memory fills up my entire 2GB allocated to Opcache, and opcache will simply stop to work. I can verify this be updating .php files and the changes show up instantly (where normally they take 90 seconds or less, based on my opcache.revalidate_freq). Thanks Alex -- Edit bug report at https://bugs.php.net/bug.php?id=80341&edit=1 -- Fix committed: https://bugs.php.net/fix.php?id=80341&r=fixed Fixed in release: https://bugs.php.net/fix.php?id=80341&r=alreadyfixed Need backtrace: https://bugs.php.net/fix.php?id=80341&r=needtrace Need Reproduce Script: https://bugs.php.net/fix.php?id=80341&r=needscript Try newer version: https://bugs.php.net/fix.php?id=80341&r=oldversion Not developer issue: https://bugs.php.net/fix.php?id=80341&r=support Expected behavior: https://bugs.php.net/fix.php?id=80341&r=notwrong Not enough info: https://bugs.php.net/fix.php?id=80341&r=notenoughinfo Submitted twice: https://bugs.php.net/fix.php?id=80341&r=submittedtwice register_globals: https://bugs.php.net/fix.php?id=80341&r=globals PHP version support discontinued: https://bugs.php.net/fix.php?id=80341&r=phptooold Daylight Savings: https://bugs.php.net/fix.php?id=80341&r=dst IIS Stability: https://bugs.php.net/fix.php?id=80341&r=isapi Install GNU Sed: https://bugs.php.net/fix.php?id=80341&r=gnused Floating point limitations: https://bugs.php.net/fix.php?id=80341&r=float No Zend Extensions: https://bugs.php.net/fix.php?id=80341&r=nozend MySQL Configuration Error: https://bugs.php.net/fix.php?id=80341&r=mysqlcfg

« previous php.bugs (#230208) next »