Bug #80359 [NEW]: Output message when opcache preload file does not exists
From: php at shyim dot de
Operating system: Docker
PHP version: 8.0.0RC4
Package: opcache
Bug Type: Bug
Bug description:Output message when opcache preload file does not exists
Description:
------------
Point opcache.preload= to a non-existing file
Run php-fpm -F
No output only exit code 70. It would be much better when we had a log
entry which says what is wrong. Maybe skip also preload?
Test script:
---------------
Point opcache.preload= to a non-existing file
Run php-fpm -F
Expected result:
----------------
Error message or runs without opcache preload with warning
Actual result:
--------------
Exits with 70
--
Edit bug report at https://bugs.php.net/bug.php?id=80359&edit=1
--
Fix committed: https://bugs.php.net/fix.php?id=80359&r=fixed
Fixed in release: https://bugs.php.net/fix.php?id=80359&r=alreadyfixed
Need backtrace: https://bugs.php.net/fix.php?id=80359&r=needtrace
Need Reproduce Script: https://bugs.php.net/fix.php?id=80359&r=needscript
Try newer version: https://bugs.php.net/fix.php?id=80359&r=oldversion
Not developer issue: https://bugs.php.net/fix.php?id=80359&r=support
Expected behavior: https://bugs.php.net/fix.php?id=80359&r=notwrong
Not enough info: https://bugs.php.net/fix.php?id=80359&r=notenoughinfo
Submitted twice: https://bugs.php.net/fix.php?id=80359&r=submittedtwice
register_globals: https://bugs.php.net/fix.php?id=80359&r=globals
PHP version support discontinued: https://bugs.php.net/fix.php?id=80359&r=phptooold
Daylight Savings: https://bugs.php.net/fix.php?id=80359&r=dst
IIS Stability: https://bugs.php.net/fix.php?id=80359&r=isapi
Install GNU Sed: https://bugs.php.net/fix.php?id=80359&r=gnused
Floating point limitations: https://bugs.php.net/fix.php?id=80359&r=float
No Zend Extensions: https://bugs.php.net/fix.php?id=80359&r=nozend
MySQL Configuration Error: https://bugs.php.net/fix.php?id=80359&r=mysqlcfg
Thread (3 messages)
- php at shyim dot de