Bug #80405 [NEW]: LDAPCONF=/etc/ldap/ldap.conf not respected
| From: | alisun at shitmail dot de | Date: | Mon, 23 Nov 2020 10:29:57 +0000 |
| Subject: | Bug #80405 [NEW]: LDAPCONF=/etc/ldap/ldap.conf not respected | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-230534@lists.php.net to get a copy of this message | ||
From: alisun at shitmail dot de
Operating system: linux
PHP version: 7.4.12
Package: *General Issues
Bug Type: Bug
Bug description:LDAPCONF=/etc/ldap/ldap.conf not respected
Description:
------------
Problem: $LDAPCONF is not read properly.
cat /etc/ldap/ldap.conf
TLS_CACERT=/some/path
TLS_KEY=/some/other/path
TLS_CERT=/some/otherpath
TLS_REQCERT=demand
Ex 1: no explicit environment variables, should respect
/etc/ldap/ldap.conf?
Does not :D
sudo -u www-data php -a<<eof
\$dn="someDN";
\$p="somePw";
\$ldaphost = "someHost";
\$ldapport = somePort;
\$ldapconn = ldap_connect(\$ldaphost, \$ldapport);
ldap_set_option(\$ldapconn, LDAP_OPT_PROTOCOL_VERSION, 3);
ldap_start_tls(\$ldapconn);
eof
PHP Warning: ldap_start_tls(): Unable to start TLS: Connect error in
php shell code on line 1
Ex 2: set LDAPCONF explicity, should respect /etc/ldap/ldap.conf?
Does not either
export LDAPCONF=/etc/ldap/ldap.conf
sudo -Eu www-data php -a<<eof
\$dn="someDN";
\$p="somePw";
\$ldaphost = "someHost";
\$ldapport = somePort;
\$ldapconn = ldap_connect(\$ldaphost, \$ldapport);
ldap_set_option(\$ldapconn, LDAP_OPT_PROTOCOL_VERSION, 3);
ldap_start_tls(\$ldapconn);
eof
PHP Warning: ldap_start_tls(): Unable to start TLS: Connect error in
php shell code on line 1
Ex 3: use $LDAPCONF content via environment variables
Works
export LDAPTLS_CACERT=/some/path
export LDAPTLS_KEY=/some/other/path
export LDAPTLS_CERT=/some/otherpath
export LDAPTLS_REQCERT=demand
sudo -Eu wwwcloud php -a<<eof
\$dn="uid=nextcloud,ou=people,dc=physsolutions,dc=org";
\$p=">.D+c'k_]^F4F8(d";
\$ldaphost = "ldap.physsolutions.org";
\$ldapport = 389;
\$ldapconn = ldap_connect(\$ldaphost, \$ldapport);
ldap_set_option(\$ldapconn, LDAP_OPT_PROTOCOL_VERSION, 3);
ldap_start_tls(\$ldapconn);
eof
# no error
Ex 4: use $HOME/.ldaprc
Works
cp /etc/ldap/ldap.conf ~www-data/.ldaprc
sudo --set-home -u www-data php -a<<eof
\$dn="someDN";
\$p="somePw";
\$ldaphost = "someHost";
\$ldapport = somePort;
\$ldapconn = ldap_connect(\$ldaphost, \$ldapport);
ldap_set_option(\$ldapconn, LDAP_OPT_PROTOCOL_VERSION, 3);
ldap_start_tls(\$ldapconn);
eof
# no error
Ex 5: use $CWD/ldaprc
Works
cp /etc/ldap/ldap.conf ldaprc
sudo -u www-data php -a<<eof
\$dn="someDN";
\$p="somePw";
\$ldaphost = "someHost";
\$ldapport = somePort;
\$ldapconn = ldap_connect(\$ldaphost, \$ldapport);
ldap_set_option(\$ldapconn, LDAP_OPT_PROTOCOL_VERSION, 3);
ldap_start_tls(\$ldapconn);
eof
# no error
--
Edit bug report at https://bugs.php.net/bug.php?id=80405&edit=1
--
Fix committed: https://bugs.php.net/fix.php?id=80405&r=fixed
Fixed in release: https://bugs.php.net/fix.php?id=80405&r=alreadyfixed
Need backtrace: https://bugs.php.net/fix.php?id=80405&r=needtrace
Need Reproduce Script: https://bugs.php.net/fix.php?id=80405&r=needscript
Try newer version: https://bugs.php.net/fix.php?id=80405&r=oldversion
Not developer issue: https://bugs.php.net/fix.php?id=80405&r=support
Expected behavior: https://bugs.php.net/fix.php?id=80405&r=notwrong
Not enough info: https://bugs.php.net/fix.php?id=80405&r=notenoughinfo
Submitted twice: https://bugs.php.net/fix.php?id=80405&r=submittedtwice
register_globals: https://bugs.php.net/fix.php?id=80405&r=globals
PHP version support discontinued: https://bugs.php.net/fix.php?id=80405&r=phptooold
Daylight Savings: https://bugs.php.net/fix.php?id=80405&r=dst
IIS Stability: https://bugs.php.net/fix.php?id=80405&r=isapi
Install GNU Sed: https://bugs.php.net/fix.php?id=80405&r=gnused
Floating point limitations: https://bugs.php.net/fix.php?id=80405&r=float
No Zend Extensions: https://bugs.php.net/fix.php?id=80405&r=nozend
MySQL Configuration Error: https://bugs.php.net/fix.php?id=80405&r=mysqlcfg