Req #45243 [Fbk->NoF]: "configure" script fails with apxs2

From: Date: Sun, 29 Nov 2020 04:22:08 +0000
Subject: Req #45243 [Fbk->NoF]: "configure" script fails with apxs2
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-230705@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=45243&edit=1

 ID:               45243
 Updated by:       php-bugs@lists.php.net
 Reported by:      talltony at breakthru dot com
 Summary:          "configure" script fails with apxs2
-Status:           Feedback
+Status:           No Feedback
 Type:             Feature/Change Request
 Package:          *Configuration Issues
 Operating System: AIX 5.3
 PHP Version:      5.2.6
 Assigned To:      cmb
 Private report:   N

 New Comment:

No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.


Previous Comments:
------------------------------------------------------------------------
[2020-11-19 17:47:50] cmb@php.net

Is that still an issue with any of the actively supported PHP
versions[1]?

[1] <https://www.php.net/supported-versions.php>

------------------------------------------------------------------------
[2008-06-12 06:17:39] talltony at breakthru dot com

Description:
------------
I'm trying to compile PHP 5.2.6 on AIX 5.3 with IBM HTTP Server (which is basically
Apache/2.0.47).

When I run the supplied configure script as follows, I get the error below:
> ./configure --with-apxs2=/usr/ihs/bin/apxs
.
.
.
with_apxs2=/usr/ihs/bin/apxs
withval=/usr/ihs/bin/apxs
x_includes=NONE
x_libraries=NONE
expr: syntax error
configure: error: You have enabled Apache 2 support while your server is Apache 1.3.  Please use the
appropiate switch --with-apxs (without the 2)

Basically, there seems to be a error in line 6707 where the script tries this:
APACHE_VERSION=expr $4 \* 1000000 + $5 \* 1000 + $6
($4, $5 and $6 have no values.)

I have tried using autoconfig to generate a new configuration file and which seems to work. However,
when I try ' buildconf --force' it fails so I'm not comfortable using my version of
configure in case buldconf performs any other magic.



------------------------------------------------------------------------



--
Edit this bug report at https://bugs.php.net/bug.php?id=45243&edit=1


Thread (3 messages)

« previous php.bugs (#230705) next »