#20034 [Fbk]: Webserver hangs on certain conditions

From: Date: Thu, 24 Oct 2002 18:13:24 +0000
Subject: #20034 [Fbk]: Webserver hangs on certain conditions
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-23219@lists.php.net to get a copy of this message
ID: 20034 Updated by: sniper@php.net Reported By: alejandro.garza@itesm.mx Status: Feedback Bug Type: iPlanet related Operating System: Solaris 8 PHP Version: 4.2.3 New Comment: Please follow the status on this bug: http://bugs.php.net/?id=20063&edit=1 And when that is fixed, try a new snapshot. Previous Comments: ------------------------------------------------------------------------ [2002-10-24 11:37:20] alejandro.garza@itesm.mx Nope, still getting same error for snapshot php4-200210240900 ... ------------------------------------------------------------------------ [2002-10-24 02:26:32] sniper@php.net Please try newer snapshot as that compile error should be fixed now. ------------------------------------------------------------------------ [2002-10-23 10:33:11] alejandro.garza@itesm.mx Downloaded latest CVS, tried with same configure line, got compile error: /bin/sh libtool --silent --mode=compile gcc -Iext/standard/ -I/usr/local/www/biblio/dev/php4-200210221500/ext/standard/ -DPHP_ATOM_INC -I/usr/local/www/biblio/dev/php4-200210221500/include -I/usr/local/www/biblio/dev/php4-200210221500/main -I/usr/local/www/biblio/dev/php4-200210221500 -I/opt/iplanet/webserver/plugins/include -I/usr/local/www/biblio/dev/php4-200210221500/Zend -I/usr/local/www/biblio/dev/mysql/include/mysql -I/usr/local/www/biblio/dev/php4-200210221500/ext/xml/expat -D_POSIX_PTHREAD_SEMANTICS -D_POSIX_PTHREAD_SEMANTICS -D_REENTRANT -I/usr/local/www/biblio/dev/php4-200210221500/TSRM -g -O2 -pthreads -DZTS -prefer-pic -c /usr/local/www/biblio/dev/php4-200210221500/ext/standard/basic_functions.c -o ext/standard/basic_functions.lo /usr/local/www/biblio/dev/php4-200210221500/ext/standard/basic_functions.c:77: getopt.h: No such file or directory *** Error code 1 make: Fatal error: Command failed for target `ext/standard/basic_functions.lo' I will try to find bugreport on this issue to fix and test... ------------------------------------------------------------------------ [2002-10-22 19:23:18] sniper@php.net Please try using this CVS snapshot: http://snaps.php.net/php4-latest.tar.gz For Windows: http://snaps.php.net/win32/php4-win32-latest.zip ------------------------------------------------------------------------ [2002-10-22 19:15:35] alejandro.garza@itesm.mx I have been testing PHP as a nsapi plugin with IPlanet 4.1 no Solaris 8 with this configuration: export CC; CC=gcc ; ./configure --with-mysql=/usr/local/www/biblio/dev/mysql --with-nsapi =/opt/iplanet/webserver --enable-libgcc PHP scripts work fine, however upons certain (unknown?) conditions, the Iplanet server stops responding. The access logs show no more responses, the Iplanet error log shows nothing. This usualy happens when there is more load upon the server. The last lines in the access log before the server lockup are for normal pages, like GIFs, HTML, etc. -- not even PHP scripts. I have had this happen within a few minutes of restarting the server, or within a few hours. When I remove links to the frequently-called scripts and replace them back to their old CGI (bleah!) counterparts, the server keeps on going with no problem. This is a high-traffic server, so this is frustrating. Does this have anything to do with thread safety? Does anyone have stability issues with IPlanet? I tried PHP 4.1.2 before installing 4.2.3, with the same results. ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=20034&edit=1

« previous php.bugs (#23219) next »