Bug #55770 [Fbk->NoF]: Missing error_log value produces 500 error

From: Date: Sun, 21 Feb 2021 04:22:13 +0000
Subject: Bug #55770 [Fbk->NoF]: Missing error_log value produces 500 error
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-232297@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=55770&edit=1 ID: 55770 Updated by: php-bugs@lists.php.net Reported by: andrew dot luebke at gmail dot com Summary: Missing error_log value produces 500 error -Status: Feedback +Status: No Feedback Type: Bug Package: IIS related Operating System: Windows Server 2008 R2 x64 PHP Version: 5.3.8 Assigned To: cmb Private report: N New Comment: No feedback was provided. The bug is being suspended because we assume that you are no longer experiencing the problem. If this is not the case and you are able to provide the information that was requested earlier, please do so and change the status of the bug back to "Re-Opened". Thank you. Previous Comments: ------------------------------------------------------------------------ [2021-02-11 13:09:19] cmb@php.net I cannot reproduce this with PHP 7.4 and IIS 10. Is this still an issue for you with any of the actively supported PHP versions[1]? [1] <https://www.php.net/supported-versions.php> ------------------------------------------------------------------------ [2011-09-26 18:53:54] andrew dot luebke at gmail dot com Log Name: Application Source: Application Error Date: 9/23/2011 2:02:23 PM Event ID: 1000 Task Category: (100) Level: Error Keywords: Classic User: N/A Computer: **** Description: Faulting application name: php-cgi.exe, version: 5.3.8.0, time stamp: 0x4e537939 Faulting module name: php5ts.dll, version: 5.3.8.0, time stamp: 0x4e537a04 Exception code: 0xc0000005 Fault offset: 0x000f8a80 Faulting process id: 0x3e00 Faulting application start time: 0x01cc7a34174de581 Faulting application path: C:\Program Files (x86)\PHP\php-cgi.exe Faulting module path: C:\Program Files (x86)\PHP\php5ts.dll Report Id: 54fcd3bf-e627-11e0-8792-000c29dca815 ------------------------------------------------------------------------ [2011-09-24 19:11:07] aharvey@php.net Are there any PHP-related errors in your IIS error log (or event log)? ------------------------------------------------------------------------ [2011-09-23 21:00:03] andrew dot luebke at gmail dot com Description: ------------ If log_errors = on and there is no error_log, i.e. error_log = php_errors.log, then any script returns a 500 error in IIS 7.5. This is the default setting in php.ini-production, both error_log entries are commented out. Test script: --------------- <?php phpinfo(); ?> Expected result: ---------------- The php info page. Actual result: -------------- 500 - Internal server error. There is a problem with the resource you are looking for, and it cannot be displayed. ------------------------------------------------------------------------ -- Edit this bug report at https://bugs.php.net/bug.php?id=55770&edit=1

« previous php.bugs (#232297) next »