Bug #80862 [Asn->Nab]: "Class not found" using Opcache & Xenforo

From: Date: Wed, 17 Mar 2021 21:42:31 +0000
Subject: Bug #80862 [Asn->Nab]: "Class not found" using Opcache & Xenforo
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-232836@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=80862&edit=1

 ID:                 80862
 Updated by:         cmb@php.net
 Reported by:        alex at ndros dot com
 Summary:            "Class not found" using Opcache & Xenforo
-Status:             Assigned
+Status:             Not a bug
 Type:               Bug
 Package:            opcache
 Operating System:   Windows Server 2019
 PHP Version:        7.4.16
 Assigned To:        cmb
 Block user comment: N
 Private report:     N

 New Comment:

> It seems that the new configuration has solved our issue.

Happy to hear that!  Thanks for the confirmation.


Previous Comments:
------------------------------------------------------------------------
[2021-03-17 20:00:55] alex at ndros dot com

Hi,

It seems that the new configuration has solved our issue.

Thank you

------------------------------------------------------------------------
[2021-03-15 19:38:47] alex at ndros dot com

ah nice, I didn't know I could use an environment var in php.ini
we've done:

opcache.cache_id=${APP_POOL_ID}

and also running different application pool for each app (joomla, xenforo).

I will report if this solves our problem.

Thanks !

------------------------------------------------------------------------
[2021-03-15 14:50:32] cmb@php.net

> We do use 2 worker processes for the IIS application pool. We
> did try to use just 1, but the error happens with this
> configuration as well.

Nonetheless, please try

    opcache.cache_id=${APP_POOL_ID}

and use separate application pools for different applications.

------------------------------------------------------------------------
[2021-03-15 14:01:51] alex at ndros dot com

Hi,

No, there's no modification on the files. This appears to happen randomly.

---Are there other PHP processes running for the same user with the
same cache_id?

I'm not sure about that. We do use 2 worker processes for the IIS application pool. We did try
to use just 1, but the error happens with this configuration as well.

----Are there any relevant warnings in the OPcache error log?

No, the OPcache error log only contains entries like:

Message Cached script
Message Added key
Debug Loading blacklist file:

------------------------------------------------------------------------
[2021-03-15 09:17:01] cmb@php.net

Does this happen after you modified some of the PHP files?

Are there other PHP processes running for the same user with the
same cache_id?

Are there any relevant warnings in the OPcache error log?

------------------------------------------------------------------------


The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at

    https://bugs.php.net/bug.php?id=80862


--
Edit this bug report at https://bugs.php.net/bug.php?id=80862&edit=1


Thread (9 messages)

« previous php.bugs (#232836) next »