Bug #80903 [NEW]: opcache with file_cache as secondary segfaults php-fpm

From: Date: Wed, 24 Mar 2021 14:13:36 +0000
Subject: Bug #80903 [NEW]: opcache with file_cache as secondary segfaults php-fpm
Groups: php.bugs 
Request: Send a blank email to php-bugs+get-232970@lists.php.net to get a copy of this message
From: jorritdeklerk at gmail dot com Operating system: FreeBSD 12.2-RELEASE-p4 PHP version: 7.4.16 Package: opcache Bug Type: Bug Bug description:opcache with file_cache as secondary segfaults php-fpm Description: ------------ On both a productionserver and development server php-fpm SOMETIMES crashes when opcache file_cache is enables as secondary cache resulting in 503 errors. The problem goes automatically away when opcache restarts after 180 seconds or when php-fpm is restarted AND the opcache file dir is emptied. The problem does not occur when file_cache is disabled or when file_cache_only is true. php.ini opcache.enable=1 opcache.memory_consumption=128 opcache.interned_strings_buffer=16 opcache.validate_timestamps=1 opcache.revalidate_freq=1 (also tried 0 and 60) opcache.file_cache="/dir/to/opcache/" opcache.force_restart_timeout=180 ;opcache.file_cache_only=1 opcache.use_cwd=1 http-error.log [Wed Mar 24 14:33:36.629648 2021] [proxy_fcgi:error] [pid 35068:tid 34385076736] [client 192.168.2.16:14655] AH01067: Failed to read FastCGI header, referer: https://example.com/admin/plugins.php [Wed Mar 24 14:33:36.629670 2021] [proxy_fcgi:error] [pid 35068:tid 34385076736] (70014)End of file found: [client 192.168.2.16:14655] AH01075: Error dispatching request to : , referer: https://example.com/admin/plugins.php /var/log/php-fpm.log [24-Mar-2021 14:33:36] WARNING: [pool www] child 43384 exited on signal 11 (SIGSEGV) after 0.241076 seconds from start [24-Mar-2021 14:33:36] NOTICE: [pool www] child 44577 started There are no problems reported when I activate an opcache log (no (fatal) errors). Problem most of the time occurs after changing / adding code to application (both tested on own application and Moodle 3.10). Tried different memory_consumptions (very small to very big); no luck. Maybe related to Bug #75670 and Bug #80154, Disabling file_cache for now. -- Edit bug report at https://bugs.php.net/bug.php?id=80903&edit=1 -- Fix committed: https://bugs.php.net/fix.php?id=80903&r=fixed Fixed in release: https://bugs.php.net/fix.php?id=80903&r=alreadyfixed Need backtrace: https://bugs.php.net/fix.php?id=80903&r=needtrace Need Reproduce Script: https://bugs.php.net/fix.php?id=80903&r=needscript Try newer version: https://bugs.php.net/fix.php?id=80903&r=oldversion Not developer issue: https://bugs.php.net/fix.php?id=80903&r=support Expected behavior: https://bugs.php.net/fix.php?id=80903&r=notwrong Not enough info: https://bugs.php.net/fix.php?id=80903&r=notenoughinfo Submitted twice: https://bugs.php.net/fix.php?id=80903&r=submittedtwice register_globals: https://bugs.php.net/fix.php?id=80903&r=globals PHP version support discontinued: https://bugs.php.net/fix.php?id=80903&r=phptooold Daylight Savings: https://bugs.php.net/fix.php?id=80903&r=dst IIS Stability: https://bugs.php.net/fix.php?id=80903&r=isapi Install GNU Sed: https://bugs.php.net/fix.php?id=80903&r=gnused Floating point limitations: https://bugs.php.net/fix.php?id=80903&r=float No Zend Extensions: https://bugs.php.net/fix.php?id=80903&r=nozend MySQL Configuration Error: https://bugs.php.net/fix.php?id=80903&r=mysqlcfg

« previous php.bugs (#232970) next »