Bug #80386 [Opn->Csd]: Configure with opcache enabled fails
| From: | cmb@php.net | Date: | Wed, 07 Jul 2021 10:24:52 +0000 |
| Subject: | Bug #80386 [Opn->Csd]: Configure with opcache enabled fails | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-234854@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=80386&edit=1
ID: 80386
Updated by: cmb@php.net
Reported by: oliver at erply dot com
Summary: Configure with opcache enabled fails
-Status: Open
+Status: Closed
Type: Bug
Package: Compile Failure
Operating System: Centos 7
PHP Version: 8.0.0RC5
-Assigned To:
+Assigned To: cmb
Block user comment: N
Private report: N
New Comment:
Seems this can be closed then.
Previous Comments:
------------------------------------------------------------------------
[2020-11-26 15:28:47] oliver at erply dot com
Thanks for help guys.
I managed to get it working by symlinking the missing libs:
- ln -s /usr/lib64/ruby/zlib.so /usr/lib64/libzlib.so
- ln -s /usr/lib64/libgnutls.so.28 /usr/lib64/libgnutls.so
------------------------------------------------------------------------
[2020-11-26 10:51:32] nikic@php.net
@oliver at erply dot com: Could you please share the whole config.log file somewhere (e.g
gist.github.com)? Not obvious where these -lgnutls -lzlib come from (usually it's -lz, not
-lzlib).
------------------------------------------------------------------------
[2020-11-24 15:32:36] oliver at erply dot com
You are correct, due testing with different configurations I messed up the /opt/ews-24-80/mysql/lib
folder.
But after adding the libmariadb.so to the correct folder. It still fails with the following error:
configure:52275: result: no
configure:52692: error: No supported shared memory caching support was found when configuring
opcache. Check config.log for any errors or missing dependencies.
In the config.log I still see the same error, only with out the lmariadb:
configure:51950: result: no
configure:52012: checking for mmap() using shm_open() shared memory support
configure:52087: cc -std=gnu99 -o conftest -g -O2 -fvisibility=hidden
-Wl,-rpath,/opt/ews-24-80/mysql/lib -L/opt/ews-24-80/mysql/lib conftest.c -lstdc++ -lbz2 -lutil -lrt
-lm -ldl -lxml2 -lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err -lssl -lcrypto -lsqlite3 -lz -lcurl
-lxml2 -licuio -licui18n -licuuc -licudata -lonig -lmariadb -ldl -lm -lgnutls -lzlib >&5
/usr/bin/ld: cannot find -lgnutls
/usr/bin/ld: cannot find -lzlib
------------------------------------------------------------------------
[2020-11-24 11:46:21] nikic@php.net
Does /opt/ews-24-80/mysql/lib contain a libmariadb.so file? (Or any other library search path.)
------------------------------------------------------------------------
[2020-11-24 11:41:30] nikic@php.net
Looks like libraries that were previously added to the LIBS haven't been found:
configure:51724: cc -std=gnu99 -o conftest -g -O2 -fvisibility=hidden
-Wl,-rpath,/opt/ews-24-80/mysql/lib -L/opt/ews-24-80/mysql/lib conftest.c -lstdc++ -lbz2 -lutil -lrt
-lm -ldl -lxml2 -lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err -lssl -lcrypto -lsqlite3 -lz -lcurl
-lxml2 -licuio -licui18n -licuuc -licudata -lonig -lmariadb -ldl -lm -lgnutls -lzlib >&5
/usr/bin/ld: cannot find -lmariadb
/usr/bin/ld: cannot find -lgnutls
/usr/bin/ld: cannot find -lzlib
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
https://bugs.php.net/bug.php?id=80386
--
Edit this bug report at https://bugs.php.net/bug.php?id=80386&edit=1