#19793 [Fbk->NoF]: Apache blames the failure of /error.php?error=# with ErrorDocument on PHP
| From: | sniper@php.net | Date: | Mon, 28 Oct 2002 01:11:56 +0000 |
| Subject: | #19793 [Fbk->NoF]: Apache blames the failure of /error.php?error=# with ErrorDocument on PHP | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-23491@lists.php.net to get a copy of this message | ||
ID: 19793
Updated by: sniper@php.net
Reported By: mordeth@pankurokku.com
-Status: Feedback
+Status: No Feedback
Bug Type: Apache2 related
Operating System: RedHat 7.1
PHP Version: 4.2.3
New Comment:
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.
Previous Comments:
------------------------------------------------------------------------
[2002-10-10 10:33:54] alindeman@php.net
Please try using this CVS snapshot:
http://snaps.php.net/php4-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php4-win32-latest.zip
------------------------------------------------------------------------
[2002-10-06 21:21:33] mordeth@pankurokku.com
I have always used this in my .htaccess:
# Error document handling:
ErrorDocument 401 /error.php?error=401
ErrorDocument 403 /error.php?error=403
ErrorDocument 404 /error.php?error=404
this works perfectly with PHP on Apache 1.3.x.
Recently, I decided to upgrade PHP and Apache to the newest version of
each on a server that I maintain, and first noticed that in directories
where I use another .htaccess for password protection, Apache was
giving me the 401 page without asking for a username and password, then
saying that it was getting a 403 error in trying to load the
ErrorDocument.
This made no sense to me, because:
DocumentRoot = /web/mori
drwxrwx--x 24 mordeth mordeth 4096 Oct 6 21:25 .
-rw-rw-r-- 1 mordeth mordeth 6731 Dec 5 2001 error.php
and in /web:
drwxr-x--x 41 root web 4096 Oct 1 23:04 .
as you can see...I have the correct perms for Apache to be able to read
that document, so I shouldn't be getting 403 errors on it.
After submitting bug #13121 to Apache
(http://nagoya.apache.org/bugzilla/show_bug.cgi?id=13121), they reject
fixing the problem, instead blaming the problem on PHP:
"This is almost certainly a PHP problem, since the default install
includes some SSI-generated error documents that work just fine. Most
likely, the reponse status code is getting lost someplace in the PHP
filter. Please ask on the PHP users mailing list, and if they don't
have a solution, report it in the PHP bug database."
I fail to see why it'd be PHP's fault that Apache wouldn't do the Auth
before serving the ErrorDocument, but hopefully someone can diagnose
this.
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=19793&edit=1