Req #33527 [Opn->Fbk]: imap_open() failes to use /authuser="" option with Cyrus server

From: Date: Wed, 18 Aug 2021 14:50:49 +0000
Subject: Req #33527 [Opn->Fbk]: imap_open() failes to use /authuser="" option with Cyrus server
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-235942@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=33527&edit=1 ID: 33527 Updated by: cmb@php.net Reported by: ed2019 at columbia dot edu Summary: imap_open() failes to use /authuser="" option with Cyrus server -Status: Open +Status: Feedback Type: Feature/Change Request Package: IMAP related Operating System: * PHP Version: * -Assigned To: +Assigned To: cmb Block user comment: N Private report: N New Comment: Is that still an issue with any of the actively supported PHP versions[1]? [1] <https://www.php.net/supported-versions.php> Previous Comments: ------------------------------------------------------------------------ [2008-05-22 10:03:12] freecityhk at hotmail dot com still get this problem in PHP under CentOS 5 is it fixed? ------------------------------------------------------------------------ [2005-08-12 21:11:06] phantasm at wgresorts dot com Has this been resolved yet? I have to agree with ed2019 that this is certainly a PHP bug because the mailutil works fine from the command line. ------------------------------------------------------------------------ [2005-08-01 15:16:57] ed2019 at columbia dot edu This is certainly a PHP bug, in the interface between php_imap and c-client. The displayed error message 'can't do authuser with this server' is incorrect, we use the mailutil program, which does authuser, with this server. ------------------------------------------------------------------------ [2005-06-30 18:44:44] ed2019 at columbia dot edu Description: ------------ The imap_open() function documentation displays using the authuser swich, to authenticate as the superuser but act as another user. This option fails against Cyrus IMAP servers, even though the underlying c-client supports it. For example: mailutil check {servername/imap/tls/novalidate-cert/authuser="cyrus"/user="uname"}INBOX works, but the imap_open() call to do the same thing does not. Reproduce code: --------------- $mbox = imap_open('{servername/imap/tls/novalidate-cert/authuser="cyrus"/user="uname"}INBOX', "cyrus","cyruspw"); Expected result: ---------------- $mbox will be a valid imap mailbox stream. Actual result: -------------- Nothing, then in the error log: [client ip.ip.ip.ip] PHP Warning: imap_open(): Couldn't open stream {mailserver/imap/tls/novalidate-cert/authuser="cyrus"/user="uname"}INBOX in /var/www/html/cyrustt/testimap.php on line 3 [client ip.ip.ip.ip] PHP Notice: (null)(): Can't do /authuser with this server (errflg=2) in Unknown on line 0 ------------------------------------------------------------------------ -- Edit this bug report at https://bugs.php.net/bug.php?id=33527&edit=1

« previous php.bugs (#235942) next »