Bug->Req #81615 [Opn]: Windows mail should support internationalized email

From: Date: Mon, 15 Nov 2021 11:05:38 +0000
Subject: Bug->Req #81615 [Opn]: Windows mail should support internationalized email
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-237761@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=81615&edit=1 ID: 81615 Updated by: cmb@php.net Reported by: gblanchet at cofomo dot com -Summary: mail function does not send SMTUTF8 flag when sending internationalized emails +Summary: Windows mail should support internationalized email Status: Open -Type: Bug +Type: Feature/Change Request Package: Mail related Operating System: Windows PHP Version: 8.0.12 Block user comment: N Private report: N New Comment: Changing to feature request per the comment above. Previous Comments: ------------------------------------------------------------------------ [2021-11-12 11:44:25] heiglandreas@php.net According to https://php.net/mail the *to*-parameter "must comply with » RFC 2822". Which does not allow anything else than ASCII. As the SMTPUTF8 flag is defined in RFC6531 which is titled "SMTP Extension for Internationalized Email". Every client and server implementation can, but does not have to, implement it. So it is perfectly valid that the mail-function for windows so far does not support Internationalized Email. If you need that feature, check out one of the many mail-libraries on https://packagist.org ------------------------------------------------------------------------ [2021-11-12 11:00:54] gblanchet at cofomo dot com Description: ------------ WHAT I DID: I try to send an email with non-ASCII characters in it (RFC6530 and the following, see https://en.wikipedia.org/wiki/International_email). WHAT I WANTED TO HAPPEN: I wanted to see the support of the EAI protocol, that is, I wanted to see the domain part converted to an A-LABEL and to see the mail function sends the SMTPUTF8 flag. WHAT ACTUALLY HAPPENED: The mail is sent as is without transferring the SMTUTF8 flag. Test script: --------------- <?php mail("email-épreuve@épreuve-acceptation-universelle.org", "TEST FROM PHP WINDOWS...", "body"); ------------------------------------------------------------------------ -- Edit this bug report at https://bugs.php.net/bug.php?id=81615&edit=1

« previous php.bugs (#237761) next »