#4248 [Opn->Csd]: Unable to run ./configure --with-cdb using cdb v0.75

From: Date: Sun, 03 Nov 2002 15:25:43 +0000
Subject: #4248 [Opn->Csd]: Unable to run ./configure --with-cdb using cdb v0.75
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-23986@lists.php.net to get a copy of this message
ID: 4248 Updated by: helly@php.net Reported By: sitz@onastick.net -Status: Open +Status: Closed Bug Type: Installation problem Operating System: Solaris 2.6 PHP Version: 4.3.0dev -Assigned To: +Assigned To: helly New Comment: This bug has been fixed in CVS. In case this was a PHP problem, snapshots of the sources are packaged every three hours; this change will be in the next snapshot. You can grab the snapshot at http://snaps.php.net/. In case this was a documentation problem, the fix will show up soon at http://www.php.net/manual/. In case this was a PHP.net website problem, the change will show up on the PHP.net site and on the mirror sites in short time. Thank you for the report, and for helping us make PHP better. I had no problems with installing CDB 0.75 but had to fix the handler. It should work now. Previous Comments: ------------------------------------------------------------------------ [2002-09-18 16:00:25] colin@easydns.com This still doesn't seem to be corrected in PHP 4.3.0-dev, which makes the --with-cdb option pretty much useless. Could one of the developers maybe look rewriting the PHP code to interface with the CDB 0.75 library? - Colin ------------------------------------------------------------------------ [2000-04-26 12:14:13] sitz@onastick.net ./configure checks for cdb_bread when passed --with-cdb. However, the CDB API has changed somewhere between 0.55 (the version that works) and version 0.75 (the version that gave me a couple of hours of headaches ;) ). Enough so that the the check performed by ./configure to see if libcdb.a works now fails. Yay. (note that cdb-0.55 *does* work, with relevant files in the same locations) My full ./configure line: ./configure \ --enable-versioning \ --with-apache=../apache_1.3.12 \ --with-aspell=/usr/local/include/aspell \ --with-ftp \ --with-gd \ --with-jpeg-dir \ --with-mysql \ --with-xml \ --with-zlib \ --with-pdflib \ --with-config-file-path=/usr/local/etc \ --enable-safe-mode \ --enable-track-vars \ --enable-force-cgi-redirect \ --enable-memory-limit \ --enable-sysvsem \ --enable-sysvshm \ --with-gdbm \ --with-db2 \ --with-cdb ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=4248&edit=1

« previous php.bugs (#23986) next »