[php-src] Issue #8334: "Out of memory" fatal error when apache memory size is big

From: Date: Tue, 12 Apr 2022 13:53:51 +0000
Subject: [php-src] Issue #8334: "Out of memory" fatal error when apache memory size is big
Groups: php.bugs 
Request: Send a blank email to php-bugs+get-240898@lists.php.net to get a copy of this message
Issue: https://github.com/php/php-src/issues/8334 Comment Author: cmb69 This does not look like a bug. The problem is that the PHP memory statistics are per *thread*, while the memory allocation is constrained per *process* (especially on x86). So if you're running Apache mod_winnt with multiple worker threads (ThreadsPerChild etc.), this issue can occur. Unless you have a particular reason to run 32bit Apache, I suggest to use a 64bit version.

« previous php.bugs (#240898) next »