#20044 [Fbk->NoF]: FreeBSD : Apache 2.0.43 + PHP 4.2.3 ( clean install ) gives error

From: Date: Fri, 08 Nov 2002 07:00:07 +0000
Subject: #20044 [Fbk->NoF]: FreeBSD : Apache 2.0.43 + PHP 4.2.3 ( clean install ) gives error
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-24324@lists.php.net to get a copy of this message
ID: 20044 Updated by: php-bugs@lists.php.net Reported By: tim@allodox.nl -Status: Feedback +Status: No Feedback Bug Type: Apache2 related Operating System: FreeBSD 4.7 PHP Version: 4.2.3 New Comment: No feedback was provided for this bug for over 2 weeks, so it is being suspended automatically. If you are able to provide the information that was originally requested, please do so and change the status of the bug back to "Open". Previous Comments: ------------------------------------------------------------------------ [2002-10-24 17:15:51] mbednarik@completecomputing.com this is a problem with php.net software, if a developer reveiws this, i would like them to include the document i left above in the readme for other freebsd users and give credit to www.squirrelmail.org ------------------------------------------------------------------------ [2002-10-24 17:12:05] mbednarik@completecomputing.com I had the same problem on our development cluster which is freebsd based. I use squirrelmail webmail ( www.squirrelmail.org ) which gave me a solution in their readme for their webmail. First configure apache like you did, I did it like this ./configure --prefix=/usr/local/wwwserv2 --enable-so --with-ssl=/usr/local/ssl --enable-ssl --enable-cgi then i did a make then a make install. Then instead of configuring php like ./configure --with-apxs2=/usr/local/wwwserv2/bin/apxs I just did ./configure then i did a make then copy the file php to you cgi-bin directory whereever your webserver lives like this cp php /usr/local/wwwserv2/cgi-bin/php then edit the httpd.conf whereever your webserver's configuration file is, and add the next 2 lines AddType application/php4script .php Action application/php4script /cgi-bin/php then and php pages should work. It is not the most efficent way to do it but it does work. Same security but might be a little slower, you might only notice it if you have a high demanding website. I hope this helps, if you have any more questions feel free to e-mail me at mbednarik@completecomputing.com ------------------------------------------------------------------------ [2002-10-23 20:54:45] iliaa@php.net Please try using this CVS snapshot: http://snaps.php.net/php4-latest.tar.gz For Windows: http://snaps.php.net/win32/php4-win32-latest.zip ------------------------------------------------------------------------ [2002-10-23 11:04:30] tim@allodox.nl Ok.. I downloaded php 4.2.3 and apache-2.0.43 and compiled them according the install thingy on http://www.php.net/manual/en/install.apache.php I first compiled Apache-2, tested it and it worked. then i compiled PHP 4.2.3 and now apache-2 gives me this error : daedalus# ./apachectl start Syntax error on line 230 of /usr/local/apache2/conf/httpd.conf: Cannot load /usr/local/apache2/modules/libphp4.so into server: /usr/local/apache2/modules/libphp4.so: Undefined symbol "pthread_getspecific" any idea what to do next ? thanx, - Tim - ------------------------------------------------------------------------ [2002-10-23 11:03:11] tim@allodox.nl Ok.. I downloaded php 4.2.3 and apache-2.0.43 and compiled them according the install thingy on http://www.php.net/manual/en/install.apache.php I first compiled Apache-2, tested it and it worked. then i compiled PHP 4.2.3 and now apache-2 gives me this error : daedalus# ./apachectl start Syntax error on line 230 of /usr/local/apache2/conf/httpd.conf: Cannot load /usr/local/apache2/modules/libphp4.so into server: /usr/local/apache2/modules/libphp4.so: Undefined symbol "pthread_getspecific" any idea what to do next ? thanx, - Tim - ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=20044&edit=1

« previous php.bugs (#24324) next »