#20316 [NEW]: Apache error loading PHP
| From: | jmr1 at vianet dot ca | Date: | Fri, 08 Nov 2002 18:16:55 +0000 |
| Subject: | #20316 [NEW]: Apache error loading PHP | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-24365@lists.php.net to get a copy of this message | ||
From: jmr1@vianet.ca
Operating system: Win 98 SE
PHP version: 4.2.3
PHP Bug Type: Apache2 related
Bug description: Apache error loading PHP
I am getting an error launching apache 2.0.43 with the php 4.2.3 module
(not the CGI). I have Win98SE
My command is this:
Apache.exe -w -f "C:\Apache\Apache2\conf\httpd.conf" -d
"C:\Apache\Apache2\."
The error is this:
Syntax error on line 978 of C:/Apache/Apache2/conf/httpd.conf:
Cannot load F:/php/sapi/php4apache.dll into server: One of the library
files
needed to run this application cannot be found.
Line 978 and on reads:
LoadModule php4_module "f:/php/sapi/php4apache.dll"
AddType application/x-httpd-php .php .php3 .phtml
AddType application/x-httpd-php-source .phps
I have php4ts.dll in both the system and system32 directories (just in
case). I tried backslashes instead which lets apache load but php won't
work.
I tried copying everything to my c: drive and updating the LoadModule line
to point to C instead of F. Same error.
I tried the LoadModule line without quotes: Same error.
There are currently 2 php4apache.dll files on my pc:
C:\php\sapi\php4apache.dll and F:\php\sapi\php4apache.dll
There are no sapi directories under the apache directory.
apache only has mod_isapi files.
I read on Mr Jacob's site that I should have put php2apache2.dll instead.
Upon trying this, I received the following error:
APACHE.EXE: module "c:\php4build\snap\sapi\apache2filter\sapi_apache2.c"
is not
compatible with this version of Apache (found 20020628, need 20020903).
Please contact the vendor for the correct version.
Thanks
John
--
Edit bug report at http://bugs.php.net/?id=20316&edit=1
--
Try a CVS snapshot: http://bugs.php.net/fix.php?id=20316&r=trysnapshot
Fixed in CVS: http://bugs.php.net/fix.php?id=20316&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=20316&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=20316&r=needtrace
Try newer version: http://bugs.php.net/fix.php?id=20316&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=20316&r=support
Expected behavior: http://bugs.php.net/fix.php?id=20316&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=20316&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=20316&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=20316&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=20316&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=20316&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=20316&r=isapi