#19759 [Com]: Apache will not start - libphp4.so: undefined symbol: core_globals_id

From: Date: Sat, 09 Nov 2002 02:47:14 +0000
Subject: #19759 [Com]: Apache will not start - libphp4.so: undefined symbol: core_globals_id
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-24382@lists.php.net to get a copy of this message
ID: 19759 Comment by: mpcribeiro@yahoo.com Reported By: jgoodspeed@bottomline.com Status: No Feedback Bug Type: Apache2 related Operating System: Linux RH 7.2 PHP Version: 4.2.3 New Comment: This bug still exists the error msg is the following: Syntax error on line 230 of httpd.conf: Cannot load modules/libphp4.so into server: ld.so.1: bin/httpd: fatal: realocation error: file modules/libphp4.so: symbol core_globals_id: referenced symbol not found" I'm trying to compile and use: Apache 2.0.43 php 4.2.3 under Solaris 9 Kind Regards, Miguel Previous Comments: ------------------------------------------------------------------------ [2002-10-20 23:32:59] sniper@php.net No feedback was provided. The bug is being suspended because we assume that you are no longer experiencing the problem. If this is not the case and you are able to provide the information that was requested earlier, please do so and change the status of the bug back to "Open". Thank you. ------------------------------------------------------------------------ [2002-10-04 16:41:36] iliaa@php.net Please try using this CVS snapshot: http://snaps.php.net/php4-latest.tar.gz For Windows: http://snaps.php.net/win32/php4-win32-latest.zip ------------------------------------------------------------------------ [2002-10-04 15:27:29] jgoodspeed@bottomline.com I have configured Apache 2.0.43 with the following: ./configure --prefix=/usr/local/apache2.0 --enable-module=most --enable-module=so PHP 4.2.3 was configured with the following: ./configure --with-apxs2=/usr/local/apache2.0/bin/apxs --with-mysql --with-xml The following was added to the httpd.conf file: LoadModule php4_module modules/libphp4.so <Files *.php> SetOutputFilter PHP SetInputFilter PHP </Files> AddType application/x-httpd-php .php .phtml .html When I try to start Apache I get the following error message: Cannot load /usr/local/apache2.0/modules/libphp4.so into server: /usr/local/apache2.0/modules/libphp4.so: undefined symbol: core_globals_id Thanks for any help! ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=19759&edit=1

« previous php.bugs (#24382) next »