#20323 [Opn->Fbk]: Apache will not start - libphp4.so: undefined symbol: core_globals_id
| From: | sniper@php.net | Date: | Sat, 09 Nov 2002 15:55:19 +0000 |
| Subject: | #20323 [Opn->Fbk]: Apache will not start - libphp4.so: undefined symbol: core_globals_id | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-24398@lists.php.net to get a copy of this message | ||
ID: 20323
Updated by: sniper@php.net
Reported By: mpcribeiro@yahoo.com
-Status: Open
+Status: Feedback
Bug Type: Apache2 related
Operating System: Solaris 9
PHP Version: 4.2.3
New Comment:
Please try using this CVS snapshot:
http://snaps.php.net/php4-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php4-win32-latest.zip
Previous Comments:
------------------------------------------------------------------------
[2002-11-08 21:34:39] mpcribeiro@yahoo.com
Hi again,
Should be read as ssl instead of sll :-) Thanks
Regards,
Miguel
------------------------------------------------------------------------
[2002-11-08 21:31:10] mpcribeiro@yahoo.com
Syntax error on line 230 of httpd.conf:
Cannot load modules/libphp4.so into server: ld.so.1: bin/httpd: fatal:
realocation error: file modules/libphp4.so: symbol core_globals_id:
referenced symbol not found"
I'm trying to compile and use:
Apache 2.0.43
php 4.2.3
Solaris 9
PHP config:
--prefix=/opt/php-4.2.3 --with-pgsql=/opt/postgresql
--with-apxs2=/opt/httpd-2.0.43/bin/apxs --with-openssl=/usr/local/sll
Apache config:
--prefix=/opt/httpd-2.0.43 --enable-sll
--enable-modules=/opt/php-4.2.3-source/libs/libphp4.a
--enable-module=so --with-sll=/usr/local/sll
HTTPD.CONF line 230 (line error that cause the error)
LoadModule php4_module modules/libphp4.so
Regards,
Miguel
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=20323&edit=1