[php-src] Issue #11232: Database connection works wirh PHP 8.0, fails with PHP 8.1

From: Date: Thu, 11 May 2023 15:28:27 +0000
Subject: [php-src] Issue #11232: Database connection works wirh PHP 8.0, fails with PHP 8.1
Groups: php.bugs 
Request: Send a blank email to php-bugs+get-244431@lists.php.net to get a copy of this message
Issue: https://github.com/php/php-src/issues/11232 Author: drambeldier ### Description The backup tool [Akeeba](https://www.akeeba.com/products/akeeba-backup.html) works correctly if the hoster's database runs under PHP 8.0. If, on the other hand, PHP 8.1 is set, there is a problem. (There is more software where this happens, not only Akeeba). The author of Akeeba says that the error message does not come from Akeeba, but from the DBMS of the hoster. Here his [description](https://www.akeeba.com/support/site-restoration/37111-workaround-for-db-restoration-error-restoring-database-access-denied-you-need-at-least-one-of-the-su.html). Resulted with 8.0: connect to database works fine. Resulted with 8.1: Message "akeeba Unable to connect to the Database: Access denied; you need (at least one of) the SUPER privilege(s) for this operation" ### PHP Version PHP 8.1 ### Operating System Unknown, happens at host

« previous php.bugs (#244431) next »