#19958 [Fbk->NoF]: lisablot.so.96: libsablot.so.96: Undefined symbol "__pure_virtual"
ID: 19958
Updated by: sniper@php.net
Reported By: online@sys4tec.com
-Status: Feedback
+Status: No Feedback
Bug Type: XSLT related
Operating System: FreeBSD 4.2-RC1
PHP Version: 4.2.3
New Comment:
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.
Previous Comments:
------------------------------------------------------------------------
[2002-10-26 12:08:34] msopacua@php.net
Did the snapshot fix the problem?
If not, can you paste the final line of the compilation process for php
- especially if -lstdc++ is in there?
recategorized
------------------------------------------------------------------------
[2002-10-17 12:32:44] sniper@php.net
Please try using this CVS snapshot:
http://snaps.php.net/php4-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php4-win32-latest.zip
------------------------------------------------------------------------
[2002-10-17 11:15:52] online@sys4tec.com
Hi!
Problem for building Expat+Sablotron with PHP and Apache.
My configuration:
FreeBSD 4.2-RC1
apache_1.3.27
./configure --enable-module=rewrite --prefix=/usr/local/apache
--enable-module=so
libiconv-1.8
./configure prefix=/usr/local/libiconv
expat-1.95.5
./configure prefix=/usr/local/expat
make buildlib make
installlib
Sablot-0.96 with Sablot-0.96.1.patch
./configure --prefix=/usr/local/sablot \
--with-expat-prefix=/usr/local/expat
--with-iconv-prefix=/usr/local/libiconv
php-4.2.3
rm config.cache
./configure \
--with-mysql --with-apxs=/usr/local/apache/bin/apxs --with-zlib
--enable-wddx \
--with-iconv=/usr/local/libiconv --with-iconv-dir=/usr/local/libiconv \
--with-expat-dir=/usr/local/expat --with-xslt
--with-xslt-sablot=/usr/local/sablot
For this config examples for test xslt-sablot not working. I get
messages like this:
------------------------------------------------------------Fatal
error: Call to undefined function: xslt_create() in
/wwwroot/home/xslt_transform/class.xslt.php on line 82
IF I add to this config key --enable-xslt, when re-starting web-server
I get message like this:
Syntax error on line 205 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp4.so into server:
/usr/local/sablot/lib/libsablot.so.96: Undefined symbol
"__pure_virtual"
/usr/local/apache/bin/apachectl start: httpd could not be started
Who know how solve this problem, please?
regards,
Sergei
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=19958&edit=1
Thread (6 messages)