#20413 [NEW]: PDF support with PDFLIB crash the apache server

From: Date: Wed, 13 Nov 2002 18:09:55 +0000
Subject: #20413 [NEW]: PDF support with PDFLIB crash the apache server
Groups: php.bugs 
Request: Send a blank email to php-bugs+get-24820@lists.php.net to get a copy of this message
From: alietss@yahoo.com Operating system: Linux RedHat 8.0 PHP version: 4CVS-2002-11-13 PHP Bug Type: PDF related Bug description: PDF support with PDFLIB crash the apache server Hi all the php developers, I'm testing php-4.3.0 in RedHat 8.0,httpd-2.0.40 from redhat packages, I built rpms for this plataform with pdf support with pdflib-4.0.3, here my configure... %configure \ --prefix=%{_prefix} \ --with-config-file-path=%{_sysconfdir} \ --enable-force-cgi-redirect \ --disable-debug \ --enable-pic \ --disable-rpath \ --enable-inline-optimization \ --with-bz2 \ --with-db3 \ --with-curl \ --with-dom=%{_prefix} \ --with-exec-dir=%{_bindir} \ --with-freetype-dir=%{_prefix} \ --with-png-dir=%{_prefix} \ --with-gd \ --enable-gd-native-ttf \ --with-ttf \ --with-gdbm \ --with-gettext \ --with-pdflib=shared \ --with-tiff-dir=%{_prefix} \ --with-ncurses \ --with-gmp \ --with-iconv \ --enable-xslt=shared \ --with-jpeg-dir=%{_prefix} \ --with-openssl \ --with-png \ --with-pspell \ --with-regex=system \ --with-xml \ --with-expat-dir=%{_prefix} \ --with-zlib \ --with-layout=GNU \ --enable-bcmath \ --enable-exif \ --enable-ftp \ --enable-magic-quotes \ --enable-safe-mode \ --enable-sockets \ --enable-sysvsem \ --enable-sysvshm \ --enable-discard-path \ --enable-track-vars \ --enable-trans-sid \ --enable-yp \ --enable-wddx \ --without-oci8 \ --with-pear=/usr/share/pear \ --with-imap=shared \ --with-imap-ssl \ --with-kerberos=/usr/kerberos \ --with-ldap=shared \ --with-mcal=shared,%{_prefix} \ --with-mcrypt=shared,%{_prefix} \ --with-mhash=shared,%{_prefix} \ --with-mysql=shared,%{_prefix} \ %if %{oracle} --with-oci8=shared \ %endif --with-pgsql=shared \ --with-snmp=shared,%{_prefix} \ --with-snmp=shared \ --with-sybase-ct=shared,%{_prefix} \ --with-xslt-sablot=shared,%{_prefix} \ --with-sablot-js=shared,%{_prefix} \ --enable-ucd-snmp-hack \ --with-unixODBC=shared \ --enable-memory-limit \ --enable-bcmath \ --enable-shmop \ --enable-versioning \ --enable-calendar \ --enable-dbx \ --enable-dio \ --enable-mcal \ and when I include in my php.ini the pdflib extensions the httpd server crash and fail to start,in the past php-4.2.4-dev was ok, this is the apache log error, [Wed Nov 13 00:41:57 2002] [notice] caught SIGTERM, shutting down /usr/sbin/httpd: relocation error: /usr/lib/php4/pdf.so: undefined symbol: PDF_get_majorversion /usr/sbin/httpd: relocation error: /usr/lib/php4/pdf.so: undefined symbol: PDF_get_majorversion /usr/sbin/httpd: relocation error: /usr/lib/php4/pdf.so: undefined symbol: PDF_get_majorversion I hope helps, bye aliet -- Edit bug report at http://bugs.php.net/?id=20413&edit=1 -- Try a CVS snapshot: http://bugs.php.net/fix.php?id=20413&r=trysnapshot Fixed in CVS: http://bugs.php.net/fix.php?id=20413&r=fixedcvs Fixed in release: http://bugs.php.net/fix.php?id=20413&r=alreadyfixed Need backtrace: http://bugs.php.net/fix.php?id=20413&r=needtrace Try newer version: http://bugs.php.net/fix.php?id=20413&r=oldversion Not developer issue: http://bugs.php.net/fix.php?id=20413&r=support Expected behavior: http://bugs.php.net/fix.php?id=20413&r=notwrong Not enough info: http://bugs.php.net/fix.php?id=20413&r=notenoughinfo Submitted twice: http://bugs.php.net/fix.php?id=20413&r=submittedtwice register_globals: http://bugs.php.net/fix.php?id=20413&r=globals PHP 3 support discontinued: http://bugs.php.net/fix.php?id=20413&r=php3 Daylight Savings: http://bugs.php.net/fix.php?id=20413&r=dst IIS Stability: http://bugs.php.net/fix.php?id=20413&r=isapi

« previous php.bugs (#24820) next »