#20412 [Com]: PDF support with PDFLIB crash the apache server
| From: | alietss at yahoo dot com | Date: | Wed, 13 Nov 2002 21:56:50 +0000 |
| Subject: | #20412 [Com]: PDF support with PDFLIB crash the apache server | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-24833@lists.php.net to get a copy of this message | ||
ID: 20412
Comment by: alietss@yahoo.com
Reported By: alietss@yahoo.com
Status: Feedback
Bug Type: PDF related
Operating System: Linux RedHat 8.0
PHP Version: 4CVS-2002-11-13
New Comment:
Hi iliaa, this is the output of the command...
[root@ecodevel php]# ldd /usr/lib/php4/pdf.so
libc.so.6 => /lib/i686/libc.so.6 (0x42000000)
/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x80000000)
[root@ecodevel php]#
Bye Aliet
Previous Comments:
------------------------------------------------------------------------
[2002-11-13 13:06:51] iliaa@php.net
can you please do:
ldd /usr/lib/php4/pdf.so
and see if this should you any missing links.
------------------------------------------------------------------------
[2002-11-13 12:12:58] derick@php.net
One bugreport is allowed of course.
------------------------------------------------------------------------
[2002-11-13 12:11:50] nicos@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the original bug instead.
Thank you for your interest in PHP.
------------------------------------------------------------------------
[2002-11-13 12:08:59] alietss@yahoo.com
Hi all the php developers, I'm testing php-4.3.0 in RedHat
8.0,httpd-2.0.40 from redhat packages, I built rpms for this plataform
with pdf support with pdflib, here my configure...
%configure \
--prefix=%{_prefix} \
--with-config-file-path=%{_sysconfdir} \
--enable-force-cgi-redirect \
--disable-debug \
--enable-pic \
--disable-rpath \
--enable-inline-optimization \
--with-bz2 \
--with-db3 \
--with-curl \
--with-dom=%{_prefix} \
--with-exec-dir=%{_bindir} \
--with-freetype-dir=%{_prefix} \
--with-png-dir=%{_prefix} \
--with-gd \
--enable-gd-native-ttf \
--with-ttf \
--with-gdbm \
--with-gettext \
--with-pdflib=shared \
--with-tiff-dir=%{_prefix} \
--with-ncurses \
--with-gmp \
--with-iconv \
--enable-xslt=shared \
--with-jpeg-dir=%{_prefix} \
--with-openssl \
--with-png \
--with-pspell \
--with-regex=system \
--with-xml \
--with-expat-dir=%{_prefix} \
--with-zlib \
--with-layout=GNU \
--enable-bcmath \
--enable-exif \
--enable-ftp \
--enable-magic-quotes \
--enable-safe-mode \
--enable-sockets \
--enable-sysvsem \
--enable-sysvshm \
--enable-discard-path \
--enable-track-vars \
--enable-trans-sid \
--enable-yp \
--enable-wddx \
--without-oci8 \
--with-pear=/usr/share/pear \
--with-imap=shared \
--with-imap-ssl \
--with-kerberos=/usr/kerberos \
--with-ldap=shared \
--with-mcal=shared,%{_prefix} \
--with-mcrypt=shared,%{_prefix} \
--with-mhash=shared,%{_prefix} \
--with-mysql=shared,%{_prefix} \
%if %{oracle}
--with-oci8=shared \
%endif
--with-pgsql=shared \
--with-snmp=shared,%{_prefix} \
--with-snmp=shared \
--with-sybase-ct=shared,%{_prefix} \
--with-xslt-sablot=shared,%{_prefix} \
--with-sablot-js=shared,%{_prefix} \
--enable-ucd-snmp-hack \
--with-unixODBC=shared \
--enable-memory-limit \
--enable-bcmath \
--enable-shmop \
--enable-versioning \
--enable-calendar \
--enable-dbx \
--enable-dio \
--enable-mcal \
and when I include in my php.ini the pdflib extensions the httpd server
crash and fail to start, this is the apache log error...
[Wed Nov 13 00:41:57 2002] [notice] caught SIGTERM, shutting down
/usr/sbin/httpd: relocation error: /usr/lib/php4/pdf.so: undefined
symbol: PDF_get_majorversion
/usr/sbin/httpd: relocation error: /usr/lib/php4/pdf.so: undefined
symbol: PDF_get_majorversion
/usr/sbin/httpd: relocation error: /usr/lib/php4/pdf.so: undefined
symbol: PDF_get_majorversion
I hope helps, bye aliet
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=20412&edit=1