#19918 [Com]: no libphp4.so produced
| From: | pbriggs at clinitech dot net | Date: | Wed, 20 Nov 2002 00:59:57 +0000 |
| Subject: | #19918 [Com]: no libphp4.so produced | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-25307@lists.php.net to get a copy of this message | ||
ID: 19918
Comment by: pbriggs@clinitech.net
Reported By: mad@dactar.ch
Status: Feedback
Bug Type: Apache2 related
Operating System: HP-UX 11.00
PHP Version: 4.3.0-pre1
New Comment:
I'm having the same problem and I'm using the latest CVS snapshot of
php4-200211200030, HP-UX 11.00 and Apache 2.0.43.
The only way I was able to work around the problem was to go into where
I have apache/modules located and rename libphp4.a to libphp4.so and
then 'make install' again. This seems to work, but when I try to start
apache, it can't use the libphp4.so. I get this error message:
Cannot load /opt/apache/modules/libphp4.so into server: Bad magic
number for shared library: /opt/apache/modules/libphp4.so
Previous Comments:
------------------------------------------------------------------------
[2002-11-10 18:30:43] iliaa@php.net
Please try using this CVS snapshot:
http://snaps.php.net/php4-latest.tar.gz
For Windows:
http://snaps.php.net/win32/php4-win32-latest.zip
------------------------------------------------------------------------
[2002-10-15 22:33:08] sniper@php.net
oopsie..the other bug is saying the compile doesn't work with apache
1.3.x...but you said that works so I'm reopening this.
------------------------------------------------------------------------
[2002-10-15 22:31:36] sniper@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the original bug instead.
Thank you for your interest in PHP.
------------------------------------------------------------------------
[2002-10-15 11:23:21] mad@dactar.ch
I can compile php with apache 2.0.43 but there's no libphp4.so
produced.
configure line :
./configure \
--enable-debug \
--with-config-file-path=/PKl01h01/soft/web/cfg \
--without-mysql \
--without-gd \
--prefix=/PKl01h01/soft/web \
--with-apxs2=/PKl01h01/soft/web/httpd/bin/apxs
make : no errors
make install :
Installing PHP SAPI module
/PKl01h01/soft/web/httpd/build/instdso.sh
SH_LIBTOOL='/PKl01h01/soft/web/httpd/build/libtool' libphp4.la
/PKl01h01/soft/web/httpd/modules
/PKl01h01/soft/web/httpd/build/libtool --mode=install cp libphp4.la
/PKl01h01/soft/web/httpd/modules/
cp .libs/libphp4.lai /PKl01h01/soft/web/httpd/modules/libphp4.la
cp .libs/libphp4.a /PKl01h01/soft/web/httpd/modules/libphp4.a
ranlib /PKl01h01/soft/web/httpd/modules/libphp4.a
chmod 644 /PKl01h01/soft/web/httpd/modules/libphp4.a
libtool: install: warning: remember to run `libtool --finish
/PKl01h01/soft/src/php4httpd/libs'
Warning! dlname not found in
/PKl01h01/soft/web/httpd/modules/libphp4.la.
Assuming installing a .so rather than a libtool archive.
chmod 755 /PKl01h01/soft/web/httpd/modules/libphp4.so
chmod: can't access /PKl01h01/soft/web/httpd/modules/libphp4.so
apxs:Error: Command failed with rc=65536
.
*** Error exit code 1
Stop.
if I look into libs directory, there's no shared library :
-rw-r--r-- 1 xxx xxx 10057366 Oct 15 18:09 libphp4.a
-rw-r----- 1 xxx xxx 698 Oct 15 18:09 libphp4.la
What can I do ??
PS : it works with apache 1.3.x
@++
JC
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=19918&edit=1