#20519 [NEW]: Apache 2 fails to start
| From: | mrm1 at msm dot cam dot ac dot uk | Date: | Wed, 20 Nov 2002 14:42:36 +0000 |
| Subject: | #20519 [NEW]: Apache 2 fails to start | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-25347@lists.php.net to get a copy of this message | ||
From: mrm1@msm.cam.ac.uk
Operating system: Solaris 9
PHP version: 4.3.0RC1
PHP Bug Type: Apache2 related
Bug description: Apache 2 fails to start
4.3.0RC1 is certainly a big step up from previous versions (it compiles
properly now); many thanks!
I ran make and make install on Apache 2.0.43 after running the configure
command:
./configure --prefix=/local/etc/apache-2.0.43 --enable-module=so \
--with-mpm=worker
I then ran make and make install on PHP 4.3.0RC1 with the configure
command
./configure --with-mysql=/local/mysql
--with-config-file-path=/local/etc/apache-2.0.43/conf'
--enable-track-vars
--enable-cli
--with-apxs2=/local/etc/apache-2.0.43/bin/apxs
--with-pear=/local/lib/php-4.2.3
This all worked fine (many thanks for fixing the compile failures of
earlier versions). Trying to start apache by issuing the command
/local/etc/apache-2.0.43/bin/apachectl start
produced the following message:
httpd: module "sapi_apache2.c" is not compatible with this version of
Apache (found 20020329, need 20020903).
Please contact the vendor for the correct version.
and no daemon started. I appreciate that this may well be an Apache funny
(I understand the interface keeps changing, and I sympathise!), but the
message at least tells me to report it here.
/local/etc/apache-2.0.43/bin/httpd -V says:
Server version: Apache/2.0.43
Server built: Oct 29 2002 10:28:26
Server's Module Magic Number: 20020903:0
Architecture: 32-bit
Server compiled with....
-D APACHE_MPM_DIR="server/mpm/worker"
-D APR_HAS_SENDFILE
-D APR_HAS_MMAP
-D APR_HAVE_IPV6
-D APR_USE_PROC_PTHREAD_SERIALIZE
-D APR_USE_PTHREAD_SERIALIZE
-D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
-D APR_HAS_OTHER_CHILD
-D AP_HAVE_RELIABLE_PIPED_LOGS
-D HTTPD_ROOT="/local/etc/apache-2.0.43"
-D SUEXEC_BIN="/local/etc/apache-2.0.43/bin/suexec"
-D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
-D DEFAULT_ERRORLOG="logs/error_log"
-D AP_TYPES_CONFIG_FILE="conf/mime.types"
-D SERVER_CONFIG_FILE="conf/httpd.conf"
Many thanks for all your hard work on producing PHP!
Mark
--
Edit bug report at http://bugs.php.net/?id=20519&edit=1
--
Try a CVS snapshot: http://bugs.php.net/fix.php?id=20519&r=trysnapshot
Fixed in CVS: http://bugs.php.net/fix.php?id=20519&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=20519&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=20519&r=needtrace
Try newer version: http://bugs.php.net/fix.php?id=20519&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=20519&r=support
Expected behavior: http://bugs.php.net/fix.php?id=20519&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=20519&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=20519&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=20519&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=20519&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=20519&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=20519&r=isapi