#15229 [Com]: unable to load dynamic module

From: Date: Thu, 21 Nov 2002 15:24:42 +0000
Subject: #15229 [Com]: unable to load dynamic module
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-25425@lists.php.net to get a copy of this message
ID: 15229 Comment by: garmagno@sit.imm.gub.uy Reported By: dev@myesys.com Status: Closed Bug Type: *Configuration Issues Operating System: win2000 PHP Version: 4.1.1 New Comment: My scenario: Server 1 Windows 98 Apache PHP 4.2.3 Server 2 Windows 95 PWS PHP 4.2.3 I tried to load any library that comes with PHP, but I couldn't (I tried in both servers). However, I used another library (the one that I needed) called php_mapscript_36.dll, and everything worked fine. This means that I installed and configured php all right. What's happening with the other libraries? Previous Comments: ------------------------------------------------------------------------ [2002-05-10 18:21:24] mark@nederland.ergens.nl Hi, This dll-loading seems magical stuff. First I got this 'specified procedure'-error only at work. The configuration there: php_gd.dll/PHP4.0.6/IIS/Win2k. But I didn't have any problem at home with configuration: php_gd.dll/PHP4.0.6/Xitami/WinXP. Like I said, trying to get php_gd2.dll. Everybody seems to know it, nobody has it for download. So I tried to get me a new PHP-version, 4.2, to test with at home. And you won't believe it... with a configuration: php_gd.dll/PHP4.2/Xitami/WinXP, now I get the 'specified procedure'-error at home. Good going. But how to solve this? Once I was a happy php_gd-user. Now I feel like a WinXP-looser. h e l p Mark ------------------------------------------------------------------------ [2002-05-09 01:10:33] mark@nederland.ergens.nl Hi, I've got the DLL found now, with all forward slashes. I am sure because first I received error: Unable to load dynamic library...specified library... and now I get the earlier mentioned: Unable to load dynamic...The specified procedure could not be found. But for this problem... nasty. I see you are using php_gd2 instead of php_gd. Could that solve my problem? I'll check out php_gd2 now. Thanks in advance... to everybody reading and thinking along. Mark ------------------------------------------------------------------------ [2002-04-29 07:16:47] manuzhai@php.net For me, it worked when I used just forward slashes and put the whole path in the extension directive, not using the extension_dir thingie. You might want to try that. Like: extension=p:/daemons/php/extensions/php_gd2.dll (My PHP is set up in quite a weird dir, but hey, it works :)) ------------------------------------------------------------------------ [2002-04-29 07:00:14] mark@nederland.ergens.nl Hi, I have the same problem, working also on Win2k with IIS5. I tried several things for this problem and switching to antoher platform isn't an option for me. I will check all slashes, directories, php.ini again soon but can there be antoher solution to this? I was thinking about security-options of Win2k. Let's say you need a special login to make dll's accessable on the server? Mark ------------------------------------------------------------------------ [2002-03-06 10:12:16] dev@myesys.com Really thanks sander@php.net, I have try to resolve my problem with your idea, but it do'esnt work. Anyway, I don't use windows anymore to run my PHP app, so.. Thank you to treat me of idiot spammer aqeel@paksys.com, you seem really professionnal, that's good for your name and the name of your company! ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/15229 -- Edit this bug report at http://bugs.php.net/?id=15229&edit=1

« previous php.bugs (#25425) next »