ID: 17552
Comment by: admin@westband.net
Reported By: wandyrer@hotmail.com
Status: No Feedback
Bug Type: Compile Failure
Operating System: Linux 2.4.18 Glibc
PHP Version: 4.2.1
New Comment:
This occurs using apache-2.0.43 and php-4.2.3 on FreeBSD4.7
Compiled with the following options:
./configure --with-mysql --with-apxs
When I run apache I get the following error:
Syntax error on line 230 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/modules/libphp4.so into server:
/usr/local/apache/modules/libphp4.so: Undefined symbol
"pthread_getspecific"
Previous Comments:
------------------------------------------------------------------------
[2002-11-21 06:33:36] tbyte@linuxbr.com.br
The same error with me when I try to start Apache service.
the configure options that I used for PHP:
--with-mysql
--with-apxs2
SO: FreeBSD 4.7
Apache: 2.0.43
PHP: 4.2.3
------------------------------------------------------------------------
[2002-11-15 10:33:11] php@stirfried.vegetable.org.uk
This occurs using apache-1.3.26 and php-4.2.3 on SuSE7.1 when using
--with-apxs.
I've tried adding LDFLAGS="-lpthread" just to persuade it to link
against that library, but it still doesn't like me - ldd on libphp4.so
makes no difference that way.
Am reverting to --with-apache instead on the off-chance it works...
------------------------------------------------------------------------
[2002-09-11 11:14:10] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.
------------------------------------------------------------------------
[2002-06-17 21:25:09] sniper@php.net
Can not reproduce this with. Please try this snapshot:
http://snaps.php.net/php4-latest.tar.gz
------------------------------------------------------------------------
[2002-06-01 07:00:04] mfischer@php.net
ah, ok, static module.
I'm reopening this since it still should work as a true DSO though.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/17552--
Edit this bug report at http://bugs.php.net/?id=17552&edit=1